Bug 1033928 - file conflict with rubygem-openshift-origin-common
Summary: file conflict with rubygem-openshift-origin-common
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openshift-origin-broker
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Troy Dawson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-24 12:38 UTC by Michael S.
Modified: 2014-03-12 19:17 UTC (History)
4 users (show)

(edit)
Clone Of:
: 1075779 (view as bug list)
(edit)
Last Closed: 2013-12-14 02:43:48 UTC


Attachments (Terms of Use)

Description Michael S. 2013-11-24 12:38:44 UTC
Description of problem:
on Fedora 20, trying to install openshift-origin-broker result in :

Transaction check error:
  file /etc/openshift/plugins.d conflicts between attempted installs of openshift-origin-broker-1.10.2.1-1.fc20.noarch and rubygem-openshift-origin-common-1.13.0.1-1.fc20.noarch

Comment 1 Troy Dawson 2013-11-25 15:36:48 UTC
I have fixed rubygem-openshift-origin-common, because that is where this was fixed upstream.

Although I am fixing this, I am a little confused.  In both packages, /etc/openshift/plugins.d is marked as a directory.  You can (or could) have multiple packages owning the same directory.

Is this conflict a "feature" that is coming in F20?  Or is this a bug in rpm?

If this is a new "feature", I would like to see the argument for it.  I currently don't agree with it.

Comment 2 Fedora Update System 2013-11-25 16:18:20 UTC
rubygem-openshift-origin-common-1.13.0.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rubygem-openshift-origin-common-1.13.0.1-2.fc20

Comment 3 Michael S. 2013-11-25 16:28:56 UTC
It could just be that the files are not identical in both rpm, because that's the main problem when you do that. IE, any file owner, group or permission change must be coordinated between the rpm, and this is not really sustainable. 

SO I would still recommend to avoid double ownership if it can be avoided.

Comment 4 Troy Dawson 2013-11-25 17:28:47 UTC
Aha, you are correct.  One has the directory owned by root, and one has it owned by apache.
I do agree with you that is possible, that directory ownership should be consolidated, which openshift upstream as been trying to do.  I was just concerned that there was a change in F20 rpm I wasn't aware of.
There have been so many other changes recently that I guess I'm a little gunshy.

Comment 5 Fedora Update System 2013-11-26 04:03:44 UTC
Package rubygem-openshift-origin-common-1.13.0.1-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-openshift-origin-common-1.13.0.1-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22101/rubygem-openshift-origin-common-1.13.0.1-2.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-12-14 02:43:48 UTC
rubygem-openshift-origin-common-1.13.0.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Michael Haller 2014-03-12 19:17:57 UTC
Let me know if I should open a new bug, however the issue seems to be occurring again with bumped versions of both packages:

Transaction check error:
  file /etc/openshift/plugins.d from install of openshift-origin-broker-1.15.1.2-1.fc20.noarch conflicts with file from package rubygem-openshift-origin-common-1.18.0.2-1.fc20.noarch


Note You need to log in before you can comment on or make changes to this bug.