Bug 103420 - krb5-libs should require e2fsprogs-devel >= 1.34
Summary: krb5-libs should require e2fsprogs-devel >= 1.34
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: krb5
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-29 22:23 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:57 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-11-18 22:51:16 UTC


Attachments (Terms of Use)

Description Kaj J. Niemi 2003-08-29 22:23:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Since krb5-libs requires libcom_err.so provided by e2fsprogs-devel it should
require a rather recent version.

Really weird things happen when mixing an older e2fsprogs(-devel) with
krb5-libs-1.3.1 or later -- up2date complains of missing symbols (since it is
using openssl which uses krb5-libs which uses ...)



Version-Release number of selected component (if applicable):
krb5-libs-1.3.1-2

How reproducible:
Always

Steps to Reproduce:
1. Upgrade krb5-libs but don't touch e2fsprogs(-devel)
2. up2date
3. 
    

Actual Results:  Interesting errors

Expected Results:  Run happily

Additional info:

Would seem a simple "Require: e2fsprogs-devel >= 1.34" would take care of this
and ensure full that all dependencies are really met.

Comment 1 Kaj J. Niemi 2003-11-18 22:51:16 UTC
% rpm -q krb5-libs
krb5-libs-1.3.1-6
% rpm -q krb5-libs --requires|grep com
libcom_err.so.2
% rpm -q --whatprovides libcom_err.so.2
e2fsprogs-1.34-1

Somehow this got fixed from libcom_err.so to libcom_err.so.2,
everything is good again. ;-)

Closing as RAWHIDE


Note You need to log in before you can comment on or make changes to this bug.