Bug 103420 - krb5-libs should require e2fsprogs-devel >= 1.34
krb5-libs should require e2fsprogs-devel >= 1.34
Product: Red Hat Raw Hide
Classification: Retired
Component: krb5 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-08-29 18:23 EDT by Kaj J. Niemi
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-11-18 17:51:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2003-08-29 18:23:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Since krb5-libs requires libcom_err.so provided by e2fsprogs-devel it should
require a rather recent version.

Really weird things happen when mixing an older e2fsprogs(-devel) with
krb5-libs-1.3.1 or later -- up2date complains of missing symbols (since it is
using openssl which uses krb5-libs which uses ...)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgrade krb5-libs but don't touch e2fsprogs(-devel)
2. up2date

Actual Results:  Interesting errors

Expected Results:  Run happily

Additional info:

Would seem a simple "Require: e2fsprogs-devel >= 1.34" would take care of this
and ensure full that all dependencies are really met.
Comment 1 Kaj J. Niemi 2003-11-18 17:51:16 EST
% rpm -q krb5-libs
% rpm -q krb5-libs --requires|grep com
% rpm -q --whatprovides libcom_err.so.2

Somehow this got fixed from libcom_err.so to libcom_err.so.2,
everything is good again. ;-)

Closing as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.