Bug 103478 - The Network Configuration tool crashes when trying to configure or activate the devices(network cards, modems)...
The Network Configuration tool crashes when trying to configure or activate t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-31 16:33 EDT by Ismael Concepcion
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 08:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ismael Concepcion 2003-08-31 16:33:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
An unhandled exception has occured. This is most likely a bug. Please save the 
crash dump and file a detailed bug report against redhat-config-network at 
http://bugzilla.redhat.com/bugzilla/
Traceback (most recent call last):
 File "/usr/sbin/neat", line 496, in on_apply_clicked self.save()
File "/usr/sbin/neat", line 320, in save self.saveProfiles()
File "/usr/sbin/neat", line 336, in saveProfiles profilelist.save()
File "usr/sbin/../share/redhat-config-network/netconfpkg/NCProfilelist.py", 
line 300. in save for i in hoconf.keys():
File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 483, in keys 
keys.append(var[1])
IndexError: list index out of range


Version-Release number of selected component (if applicable):
Linux Red Hat 8.0, kernel-2.4.18-14

How reproducible:
Always

Steps to Reproduce:
1. I open the Network Configuration interface. 
2. I highlight the network card and check the box beside it.
3. Then press the Apply Button. 
Note: The same thing happens when I try to configure the modem too, using the 
same steps here.

    

Actual Results:  That's when the Exception Dialog Window opens with the Bug 
message described in the Description box above. I click on the Debug Button and 
nothing happens. Then I click on the Save to file Button and since I don't know 
to which file I'm going to save the dump file
Comment 1 Josef Komenda 2003-09-02 10:05:06 EDT
Network config, not Red Hat Network. 
Comment 2 Harald Hoyer 2004-09-21 08:08:18 EDT
An errata has been issued which should help the problem described in
this bug report. 
This report is therefore being closed with a resolution of ERRATA. For
more information
on the solution and/or where to find the updated files, please follow
the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html


Note You need to log in before you can comment on or make changes to this bug.