Bug 103493 - less.sh/less.csh should not set JLESSCHARSET for UTF-8 locales
Summary: less.sh/less.csh should not set JLESSCHARSET for UTF-8 locales
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: less   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-01 06:57 UTC by Jungshik Shin
Modified: 2017-02-23 19:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-23 19:19:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jungshik Shin 2003-09-01 06:57:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:

I use ko_KR.UTF-8 locale and found that all Korean characters were turned by
less to '&&&' after upgrading to RH 9.0. It turned out that
/etc/profile.d/less.sh set JLESSCHARSET to 'ko' for any ko* locale. I changed
the script not to set it if I'm running in UTF-8 locale and it works fine. A
similar fix is necessary for /etc/profile.d/less.csh


I don't know whether RH 9.0 supports UTF-8 locales for CJK. I had used  my own
CJK locales for RH 8.0 before upgrading to RH 9.0 and I didn't bother to check
if RH 9.0 came with CJK UTF-8 locales. If it still uses legacy codeset t for
CJK, it's very much disappointing. Anyway, in that case, this bug would be invalid. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.set LC_ALL to ko_KR.UTF-8 or ja_JP.UTF-8
2.spawn a new shell or a new terminal 
3.try to view any UTF-8 files (with non-ASCII characters) 
with less

    

Actual Results:  All non-ascii characters are turned to &'s

Expected Results:  Non-ascii characters should be displayed

Additional info:

Comment 1 Jungshik Shin 2003-09-01 07:00:45 UTC
see also bug 88868 comment #5


Comment 2 Karsten Hopp 2003-09-01 14:32:00 UTC
The current less.[c]sh files parse the LC_ALL and LANG variables differently 

Comment 3 Jungshik Shin 2003-09-01 14:55:44 UTC
Does it check LC_CTYPE as well? It has to.


Comment 4 Jindrich Novy 2005-10-19 09:35:17 UTC
This works for me with the current less.

Comment 5 Fedora Update System 2017-02-19 19:11:42 UTC
libreoffice-5.1.6.2-7.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3453b4764a

Comment 6 Fedora Update System 2017-02-20 20:23:10 UTC
libreoffice-5.1.6.2-7.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3453b4764a

Comment 7 Fedora Update System 2017-02-23 19:19:49 UTC
libreoffice-5.1.6.2-7.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.