Bug 103502 - up2date segfaults with RH9/fails with --nox
Summary: up2date segfaults with RH9/fails with --nox
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-01 10:21 UTC by Nick Gould
Modified: 2007-04-18 16:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 19:00:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As requested, results from `strace -o strace.out -f /usr/sbin/up2date` (528.09 KB, text/plain)
2003-09-03 08:59 UTC, Nick Gould
no flags Details

Description Nick Gould 2003-09-01 10:21:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
2 things:

1. Latest up2date returns immediately. If run instead as
   /usr/sbin/up2date, it exits here with a segmentation error.
   Full debug ends 
   ...

# /usr/lib/python2.2/keyword.pyc matches   /usr/lib/python2.2/keyword.py
import keyword # precompiled from /usr/lib/python2.2/keyword.pyc
import ORBit # dynamically loaded from /usr/lib/python2.2/site-packages/ORBit.so
Segmentation fault

2. Without X, 

up2date --update --nox

Error Message:
    Please run rhn_register (or up2date --register on Red Hat Linux 8.0)
as root on this client
Error Class Code: 9
Error Class Info: Invalid Server Certificate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

(this following the latest up2date-3.1.23.2-1.i386.rpm updates)

Any ideas?

Nick

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /usr/sbin/up2date
2. up2date --update --nox
3.
    

Actual Results:  1. Segmentation fault
2. 
Error Message:
    Please run rhn_register (or up2date --register on Red Hat Linux 8.0)
as root on this client
Error Class Code: 9
Error Class Info: Invalid Server Certificate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.



Expected Results:  Well, I had hoped to be able to use up2date ...

Additional info:

This doesn't happen with my RH 7.3 and RH. 8 machines

Comment 1 Adrian Likins 2003-09-02 19:13:44 UTC
the X case looks very odd. Looks like a segfault in the orbit module
possibly. But then, I dont ever import the ORBit module (at least
not directly).

could you try to get a `strace -o strace.out -f /usr/sbin/up2date`
and attach the output to this bug report? 

If I had to guess, it would be that there are some corrupted
libs or modules somewhere causing the segfault. But thats based
on me not having seen a report of this before, and the odd place
it seems to be segfaulting. Could you try a `rpm -Va ` and see
if anything unexpected pops up (particular libs or python modules
with modified md5sums). But this is just a shot in the dark. 


Comment 2 Nick Gould 2003-09-03 08:59:46 UTC
Created attachment 94163 [details]
As requested, results from `strace -o strace.out -f /usr/sbin/up2date`

rpm -Va  didn't seem to suggest anything odd

Thanks for the prompt reply

Nick

Comment 3 Adrian Likins 2004-08-24 19:00:58 UTC
havent seen any reports of this issue with current releases, so
closing


Note You need to log in before you can comment on or make changes to this bug.