Bug 103521 - Modifies properties of non-Gnome applications
Modifies properties of non-Gnome applications
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: control-center (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 15:13 EDT by Enrico Scholz
Modified: 2013-04-02 00:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:25:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-09-01 15:13:30 EDT
[I do not know if this is the right Gnome-component, but it sounds reasonable.
Please reassign if needed]

Description of problem:

When start Gnome from the recent rawhide-snapshot, the colors of some non-Gnome
applications are totally broken. E.g. see

http://www.tu-chemnitz.de/~ensc/colors-broken.png


When invoking 'xrdb ~/.Xresources', things are fine again and XEmacs looks like

http://www.tu-chemnitz.de/~ensc/colors-good.png


Executing 'gnome-theme-manager' and selecting another theme, breaks the colors
again (not the background, but the scrollbars).

This is very bad since Gnome has nothing in common with (X)Emacs and should not
touch its properties therefore.


Version-Release number of selected component (if applicable):

gnome-desktop-2.3.7-1
gnome-session-2.3.7-1
control-center-2.3.5-2
redhat-artwork-0.80-1
Comment 1 Dams 2003-10-24 20:49:24 EDT
Same problem here. If this is not to be disabled (using gconf or whatever), i
suggest removing this "feature" at all.
Comment 2 Jonathan Blandford 2003-10-27 15:22:19 EST
It's a feature.  It syncs Xt-style widgets with the current theme.
Comment 3 Dams 2003-10-27 15:28:00 EST
If we cannot disable this, it is a bug.
Comment 4 Enrico Scholz 2003-10-27 15:32:00 EST
http://www.tu-chemnitz.de/~ensc/colors-broken.png is a bug and not a feature.

Comment 5 Jonathan Blandford 2003-10-27 15:39:32 EST
If you really want to change it on your machine, you can edit/remove the .ad
files in /usr/share/control-center-2.0/xrdb/.  But I think it's nice that older
apps follow the current theme.

Comment 6 Dams 2003-10-27 16:51:39 EST
It is nice, truly. I have nothing against this thing you call feature as long as
it doesnt override X resources already set by the user. 

I dont care if i have to use gconf-editor to make things like i want them to be,
but the current behaviour is pure narrow-mindness. And this is something i will
never accept from a Linux desktop environment 

So let's re-open the bug, change it's Summary to "Add a checkbox in
gnome-theme-manager to disable X resources overriding", and make everybody being
happy. Just my opinion.
Comment 7 Jonathan Blandford 2003-10-27 17:03:49 EST
How do I know which ones are set by the user?  Adding a user-visible checkbox is
clearly wrong.  What exactly is the issue here -- is it that changing emacs to
have the normal theme-textbox is undesired?
Comment 8 Enrico Scholz 2003-10-27 17:20:16 EST
(X)Emacs is not a Gnome2 application and is configured separately (with
.Xresources, init.el, ...). Therefore, Gnome2 should not try to change the
settings. 

When the user wants a white Emacs background, he can configure it with the known
methods. This does not need unpredictable magic through control-center.


To your question: the issue is http://www.tu-chemnitz.de/~ensc/colors-broken.png
Comment 9 Enrico Scholz 2005-06-09 12:25:30 EDT
Still with control-center-2.10.1-5
Comment 10 Hans de Goede 2005-06-09 13:03:28 EDT
Couldn't this be easily fixed by using a correct parsing order, iow, first parse
the gnome-theme supplied Xresources, then the global ones in /etc/X11/Xresources
and then the ones in ~/.Xresources?

That way any global or user specific local settings will override the gnome
theme, right?
Comment 11 Enrico Scholz 2005-06-09 13:48:55 EDT
The problem with this method would be, that it vould override default settings
of the application. E.g. when Emacs calculates the resource X based on Y, and
Gnome2 would set X, changes in Y would not be reflected in X. Usually,
applications itself know best how X can be calculated optimally, so an explicit
setting of 'X' might be not optimal.

So I would prefer an explicit option to disable the applying of the Gnome2 theme.
Comment 12 Hans de Goede 2005-06-09 14:01:45 EDT
Now you're contradicting yourself, first you complain that you're custom
settings are gone
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=103521#c0), and now you
complain that gnome will override any default settings. Which is the whole idea
of this feature, to make the defaults be the gnome theme settings.
Comment 13 Enrico Scholz 2005-06-09 14:18:01 EDT
The default settings of the application might be different from the default
settings of the Gnome2 theme. I do not see a contradiction there.
Comment 14 Bill Nottingham 2006-08-07 21:35:07 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 15 Bill Nottingham 2006-10-18 15:25:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.