Bug 103527 - audigy driver cause hard lock of kernel
audigy driver cause hard lock of kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-01 17:47 EDT by Denis Hennessy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: 421
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 19:05:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of sysreport (252.80 KB, application/octet-stream)
2003-09-01 17:49 EDT, Denis Hennessy
no flags Details
log from serial console (11.81 KB, text/plain)
2003-09-01 17:49 EDT, Denis Hennessy
no flags Details
output of lspci -vv (9.68 KB, text/plain)
2003-09-01 17:50 EDT, Denis Hennessy
no flags Details
output of lsmod (1.52 KB, text/plain)
2003-09-01 17:50 EDT, Denis Hennessy
no flags Details
copy of /proc/meminfo (729 bytes, text/plain)
2003-09-01 17:50 EDT, Denis Hennessy
no flags Details
copy of /proc/cpuinfo (908 bytes, text/plain)
2003-09-01 17:51 EDT, Denis Hennessy
no flags Details

  None (edit)
Description Denis Hennessy 2003-09-01 17:47:51 EDT
Description of problem: 
I have a dual-athlon computer with an audigy sound card. The soundcard 
detection app detects the audigy but fails to produce any sound. When I type 
some characters into the address field in mozilla, the computer will lock hard 
and produce the stack trace (attached) on a serial console. Since the stack 
trace is primarily made up of the audigy driver, I presume that's where the 
problem lies. This computer and sound card worked fine with RH9. 
 
Version-Release number of selected component (if applicable): 
kernel-2.4.21-1.1931.2.411.ent 
 
How reproducible: 
Every time. 
 
Steps to Reproduce: 
1.Boot computer 
2.Start Mozilla 
3.Type 3/4 characters into web address box in mozilla 
     
Actual results: 
Computer will freeze. Stack dump on attached serial console. 
 
Expected results: 
No freeze. 
 
Additional info: 
Attached next will be console log, sysreport output and output of lspci, 
lsmod, /proc/meminfo, /proc/cpuinfo
Comment 1 Denis Hennessy 2003-09-01 17:49:19 EDT
Created attachment 94122 [details]
output of sysreport
Comment 2 Denis Hennessy 2003-09-01 17:49:44 EDT
Created attachment 94123 [details]
log from serial console
Comment 3 Denis Hennessy 2003-09-01 17:50:11 EDT
Created attachment 94124 [details]
output of lspci -vv
Comment 4 Denis Hennessy 2003-09-01 17:50:32 EDT
Created attachment 94125 [details]
output of lsmod
Comment 5 Denis Hennessy 2003-09-01 17:50:57 EDT
Created attachment 94126 [details]
copy of /proc/meminfo
Comment 6 Denis Hennessy 2003-09-01 17:51:18 EDT
Created attachment 94127 [details]
copy of /proc/cpuinfo
Comment 7 Denis Hennessy 2003-09-01 17:53:24 EDT
This is reported against the .411 kernel. It also happened with the .399 
kernel. 
Comment 9 Denis Hennessy 2003-09-05 19:05:39 EDT
This appears to be fixed in the .421 release of the kernel.

Note You need to log in before you can comment on or make changes to this bug.