Bug 103535 - wireless interface doesn't show up
Summary: wireless interface doesn't show up
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-02 00:47 UTC by andi
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-08 13:04:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description andi 2003-09-02 00:47:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have set up two devices with "neat". One ethernet and one wireless. I have
checked the "Allow all users to enable/disable this device" checkbox. I have
restarted networking, and then as a regular user fired up "Network Device
Control", which shows me ONLY the ethernet card, and not the wireless.

Version-Release number of selected component (if applicable):
redhat-config-network-1.2.15-1

How reproducible:
Always

Steps to Reproduce:
1. Create wireless interface with "neat"
2. Save changes + restart networking
3. Run "Network Device Control"
    

Actual Results:  The device didn't show up in the list.

Expected Results:  The wireless device should be in the list of available devices.

Additional info:

Comment 1 Harald Hoyer 2003-09-08 13:04:37 UTC
I am sorry... neat does chown 0600 on the ifcfg-* of the wireless device, so
redhat-control-network cannot read it. This was because of the key. 
The version from Taroon (Red Hat Enterprise Linux Beta) and Cambridge (Red Hat
Linux) split the key into a seperate file and the initscripts know about this.



Note You need to log in before you can comment on or make changes to this bug.