Bug 103559 - up2date fails to resolve dependencies across multi-arch packages
up2date fails to resolve dependencies across multi-arch packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks: 97942
  Show dependency treegraph
 
Reported: 2003-09-02 09:34 EDT by Paul Nasrat
Modified: 2007-04-18 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 3.9.22-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 18:05:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2003-09-02 09:34:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
up2date fails to recognize updates with mixed arch packages, eg glibc and openssl

rpm -q --qf='%{name}-%{version}-%{release}.%{arch}\n' openssl
openssl-0.9.7a-16.i686
rpm -q --qf='%{name}-%{version}-%{release}.%{arch}\n' openssl-devel
openssl-devel-0.9.7a-16.i386
                                                                                
up2date openssl
...
                                                                                
Testing package set / solving RPM inter-dependencies...
warning: package openssl = 0.9.7a-17 was already added, replacing with openssl
<= 0.9.7a-17
There was a package dependency problem. The message was:
                                                                                
Unresolvable chain of dependencies:
openssl-devel-0.9.7a-16                  requires openssl = 0.9.7a-16
openssl-perl-0.9.7a-16                   requires openssl = 0.9.7a-16


Version-Release number of selected component (if applicable):
up2date-3.9.18-2

How reproducible:
Always

Steps to Reproduce:
1. Install severn and beta up2date
2. Add severn updates channel to rhn
3. up2date glibc
    

Actual Results:  Error message

Expected Results:  Subpackages of different arch (i386 in this case) to main
package (i686) should be replaced

Additional info:

Workaround:

up2date -u glibc glibc-utils glibc-debug nptl-devel

rpm -q '--qf=%{arch}\n' glibc glibc-utils glibc-debug nptl-devel
i686
i386
i386
i686

I'm guessing it's somewhere in the depSolver.py
Comment 1 Adrian Likins 2003-09-02 17:33:41 EDT
try 3.9.22 it fixes a dep solve bug that crept in 3.9.1x or so
Comment 2 Paul Nasrat 2003-09-03 03:35:59 EDT
3.9.22-2 fixes this for me on i686.

Cheers

Paul
Comment 3 Matt Jamison 2003-09-05 14:14:12 EDT
confirmed.  it works.

Note You need to log in before you can comment on or make changes to this bug.