Bug 103587 - Cannot build Perl module Module::Build
Summary: Cannot build Perl module Module::Build
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-02 18:37 UTC by Need Real Name
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-14 22:26:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2003-09-02 18:37:50 UTC
Description of problem:

I cannot build Module::Build on Red Hat 9.
I've tried both installing from source, and with the CPAN shell.

I reported this to the maintainer of the module and he suggested that it is a
locale problem, since I'm getting quoting errors, e.g.
 "/xs............ok 6/11Can't exec "gcc'": No such file or directory at"
-----------------------------------^^^^^^

If I set the environment variable
 LC_ALL=C
the module builds fine.

Comment 1 Need Real Name 2003-09-02 18:39:25 UTC
Bug reported to maintainer of Module::Build:
 http://rt.cpan.org/NoAuth/Bug.html?id=3687

Comment 2 Need Real Name 2003-11-19 22:28:12 UTC
Building modules using the CPAN shell with Perl is a BIG pain.

Will this be fixed in the future?

I can't rely on RPMs being made available. I'd like to use CPAN.

Comment 3 Need Real Name 2004-04-01 17:50:30 UTC
Is there any progress on this? I've reported this with no feedback at all.
If the CPAN shell doesn't work on Red Hat for some modules, there
needs to be a way to integrate the CPAN shell with up2date to fetch
the non-working modules.

Comment 4 Need Real Name 2004-04-14 22:26:05 UTC
I'm going to put this down to the build of Perl in Red Hat 9 being broken.

i.e. Perl will not work for a locale for which utf8 is allowed.

Closing as a bug.


Note You need to log in before you can comment on or make changes to this bug.