Bug 1035879 - openstack-dashboard-theme login templates out of date
Summary: openstack-dashboard-theme login templates out of date
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon   
(Show other bugs)
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 4.0
Assignee: Matthias Runge
QA Contact: Nir Magnezi
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 978574
TreeView+ depends on / blocked
 
Reported: 2013-11-28 17:58 UTC by Julie Pichon
Modified: 2015-02-15 22:02 UTC (History)
7 users (show)

Fixed In Version: python-django-horizon-2013.2-6.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 00:39:56 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC

Description Julie Pichon 2013-11-28 17:58:17 UTC
Description of problem:
The _login.html in openstack_dashboard_theme/templates/auth/_login.html out of date and needs a refresh based on https://github.com/openstack/horizon/blob/stable/havana/horizon/templates/auth/_login.html . It's blocking bug 978574.

Version-Release number of selected component (if applicable):
python-django-horizon-2013.2-5.el6ost
openstack-dashboard-2013.2-5.el6ost
openstack-dashboard-theme-2013.2-5.el6ost

Comment 2 Matthias Runge 2013-11-29 08:51:13 UTC
Ugh, I'm very sorry. Will fix that ASAP!

Comment 6 Julie Pichon 2013-12-18 14:32:07 UTC
Before this was fixed, bug 978574 was blocked (cf. comment 6 on that one). Based on this, here are my suggested instructions on how to test:

1. Ensure openstack-dashboard-theme is installed
2. Change SESSION_TIMEOUT in /etc/openstack-dashboard/local_settings to 30 and restart httpd
3. Log in to the dashboard
4. Wait for 30 seconds then click on any link e.g. "Instances"
5. Check that a message about session timeout is displayed on the login page

Before this fix, the message in step 5 could not be displayed. (Steps 2 to 5 are verification steps for bug 978574.)

Comment 7 Nir Magnezi 2013-12-18 15:52:54 UTC
Verified NVR: 
# rpm -qa | grep horizon
python-django-horizon-2013.2-8.el6ost.noarch
# rpm -qa | grep dashboard
openstack-dashboard-theme-2013.2-8.el6ost.noarch
openstack-dashboard-2013.2-8.el6ost.noarch

Followed Julie's instructions (thanks!) in comment #6.

Result:
=======
I was forced logged-out with the following message: Session timed out.

Comment 9 errata-xmlrpc 2013-12-20 00:39:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.