Bug 1035902 - Attempted update of lxpanel 0.6.1-1 to 0.6.1-2 produces dependency errors
Summary: Attempted update of lxpanel 0.6.1-1 to 0.6.1-2 produces dependency errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxpanel
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-28 19:09 UTC by D. Charles Pyle
Modified: 2013-12-10 06:57 UTC (History)
1 user (show)

Fixed In Version: lxpanel-0.6.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-10 06:57:24 UTC


Attachments (Terms of Use)

Description D. Charles Pyle 2013-11-28 19:09:20 UTC
Description of problem:
Cannot update to 0.6.1-2 of lxpanel.

Version-Release number of selected component (if applicable):
See above.

How reproducible:
100% reproducible.

Steps to Reproduce:
1. sudo yum upgrade lxpanel
2. Dependency errors generated
3. update fails.
4. Attempt to remove menu-cache or downgrade the same causes just about entire lxde groups offered to be removed.

Actual results:
The following error is generated:

Loaded plugins: dellsysid, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package lxpanel.x86_64 0:0.6.1-1.fc20 will be updated
---> Package lxpanel.x86_64 0:0.6.1-2.fc20 will be an update
--> Processing Dependency: libmenu-cache.so.2()(64bit) for package: lxpanel-0.6.1-2.fc20.x86_64
--> Finished Dependency Resolution
Error: Package: lxpanel-0.6.1-2.fc20.x86_64 (updates-testing)
           Requires: libmenu-cache.so.2()(64bit)
           Available: menu-cache-0.4.1-3.fc20.x86_64 (fedora)
               libmenu-cache.so.2()(64bit)
           Installed: menu-cache-0.5.1-1.fc20.x86_64 (@updates-testing)
              ~libmenu-cache.so.3()(64bit)

Expected results:
Successful upgrade to latest lxpanel without dependency errors and without removing nearly the whole lxde group.

Additional info:
An additional problem that I see with the previous version is that if you have two displays and put lxpanel on the bottom, half of it completely disappears from the primary display if it does not have the same height in the resolution as the secondary monitor.  Putting it on top shows the entire panel.  I do not know whether the newest update fixes that problem but I did want to proceed with the update.

Comment 1 Christoph Wickert 2013-11-29 19:33:55 UTC
(In reply to D. Charles Pyle from comment #0)

> Error: Package: lxpanel-0.6.1-2.fc20.x86_64 (updates-testing)
>            Requires: libmenu-cache.so.2()(64bit)
>            Available: menu-cache-0.4.1-3.fc20.x86_64 (fedora)
>                libmenu-cache.so.2()(64bit)
>            Installed: menu-cache-0.5.1-1.fc20.x86_64 (@updates-testing)
>               ~libmenu-cache.so.3()(64bit)

That's my fault. The package should be built against mennu-cache 0.5.1 already, but it's still in updates-testing and the buildroot overrride had run out. Need to do another rebuild.

> Additional info:
> An additional problem that I see with the previous version is that if you
> have two displays and put lxpanel on the bottom, half of it completely
> disappears from the primary display if it does not have the same height in
> the resolution as the secondary monitor.  Putting it on top shows the entire
> panel.  I do not know whether the newest update fixes that problem but I did
> want to proceed with the update.

One bug report = one problem, otherwise we will never be able to close tickets.

I think this problem should be discussed in upstream's bugtracker as it is not Fedora-specific.

Comment 2 Fedora Update System 2013-11-29 20:43:13 UTC
lxpanel-0.6.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-22291/lxpanel-0.6.1-3.fc20

Comment 3 Fedora Update System 2013-12-01 17:41:03 UTC
Package lxpanel-0.6.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxpanel-0.6.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22291/lxpanel-0.6.1-3.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-12-03 02:45:31 UTC
lxpanel-0.6.1-3.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21536/lxpanel-0.6.1-3.fc20,lxlauncher-0.2.2-4.fc20,pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20,libfm-1.1.2.2-3.fc20,menu-cache-0.5.1-1.fc20

Comment 5 Fedora Update System 2013-12-10 06:57:24 UTC
lxpanel-0.6.1-3.fc20, lxlauncher-0.2.2-4.fc20, pcmanfm-1.1.2-3.D20130830gitfc8adaab77.fc20, libfm-1.1.2.2-3.fc20, menu-cache-0.5.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.