Bug 103613 - boot fails to load Asus Laptop ACPI Extras (?!?) on a Dell Inspiron 8000
boot fails to load Asus Laptop ACPI Extras (?!?) on a Dell Inspiron 8000
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 105853 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-02 19:12 EDT by Alexandre Oliva
Modified: 2015-01-04 17:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-23 12:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from /usr/sbin/acpidmp (53.54 KB, text/plain)
2003-09-23 12:03 EDT, John Reiser
no flags Details
output from /usr/sbin/dmidecode (3.97 KB, text/plain)
2003-09-23 12:04 EDT, John Reiser
no flags Details

  None (edit)
Description Alexandre Oliva 2003-09-02 19:12:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
While booting my Dell Inspiron 8000 with acpi=off, I get this amusing error
message in the Actual Results section below:

why is it even trying to load Asus Laptop ACPI Extras if this is not an Asus laptop?

Version-Release number of selected component (if applicable):
kernel-2.4.21-20.1.2024.2.26.nptl

How reproducible:
Always

Steps to Reproduce:
1.Boot with acpi=off (I'm not sure it's needed, but that's the way I boot it)

Actual Results:  
Asus Laptop ACPI Extras version 0.24a
  Couldn't get the DSDT table header
  Error registering Asus Laptop ACPI Extras Driver
        -0420: *** Error: Could not allocate an object descriptor

(from dmesg output, but I saw it flying by early in the boot process)

Expected Results:  None like this.  This is not an Asus laptop, after all.

Additional info:
Comment 1 Alexandre Oliva 2003-09-04 00:59:40 EDT
kernel-2.4.22-20.1.2024.2.36.nptl has it as well.
Comment 2 John Reiser 2003-09-23 12:01:35 EDT
I get the same thing for SiS730 chipset on Amptron K7-810 mainboard, BIOS by
AMI.  I will attach output from /usr/sbin/dmidecode and /usr/sbin/acpidmp.

/var/log/messages has:
=====

Sep 23 08:45:37 severn kernel: BIOS-provided physical RAM map:
Sep 23 08:45:37 severn kernel:  BIOS-e820: 0000000000000000 - 000000000009fc00
(usable)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 000000000009fc00 - 00000000000a0000
(reserved)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 00000000000f0000 - 0000000000100000
(reserved)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 0000000000100000 - 000000002fff0000
(usable)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 000000002fff0000 - 000000002fff8000
(ACPI data)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 000000002fff8000 - 0000000030000000
(ACPI NVS)
Sep 23 08:45:37 severn kernel:  BIOS-e820: 00000000fffc0000 - 0000000100000000
(reserved)
     [snip]
Sep 23 08:45:37 severn kernel: ACPI disabled because your bios is from 97      
                  and too old
Sep 23 08:45:37 severn kernel: You can enable it with acpi=force
Sep 23 08:45:37 severn kernel: ACPI: RSDP (v000 AMI                            
          ) @ 0x000fc390
Sep 23 08:45:37 severn kernel: ACPI: RSDT (v001 AMIINT SiS730SX 0x00001000 MSFT
0x0100000b) @ 0x2fff0000
Sep 23 08:45:37 severn kernel: ACPI: FADT (v001 AMIINT SiS730SX 0x00001000 MSFT
0x0100000b) @ 0x2fff0030
Sep 23 08:45:37 severn kernel: ACPI: DSDT (v001    SiS     730S 0x00000100 MSFT
0x0100000b) @ 0x00000000
     [snip]
Sep 23 08:45:38 severn kernel: ACPI: Subsystem revision 20030813
Sep 23 08:45:38 severn kernel: ACPI: Interpreter disabled.
     [snip]
Sep 23 08:45:38 severn kernel: Asus Laptop ACPI Extras version 0.24a
Sep 23 08:45:38 severn kernel:   Couldn't get the DSDT table header
Sep 23 08:45:38 severn kernel:   Error registering Asus Laptop ACPI Extras Driver
Sep 23 08:45:38 severn kernel:         -0420: *** Error: Could not allocate an
object descriptor
=====
Comment 3 John Reiser 2003-09-23 12:03:42 EDT
Created attachment 94652 [details]
output from /usr/sbin/acpidmp

kernel is Linux severn 2.4.22-1.2051.nptl #1 Wed Sep 17 21:30:08 EDT 2003 i686
athlon i386 GNU/Linux
Comment 4 John Reiser 2003-09-23 12:04:24 EDT
Created attachment 94653 [details]
output from /usr/sbin/dmidecode
Comment 5 Dave Jones 2003-09-23 12:20:49 EDT
I just changed these to be modules.
They'll appear in a 2062 and above.
Comment 6 Dave Jones 2003-09-28 21:04:10 EDT
*** Bug 105853 has been marked as a duplicate of this bug. ***
Comment 7 Alexandre Oliva 2003-10-18 22:31:59 EDT
Confirmed fixed in 2097 (with acpi=on).  Sorry about the delay.

Note You need to log in before you can comment on or make changes to this bug.