Bug 1036310 - [abrt] rpmlint-1.5-5.fc19: TagsCheck.py:490:spell_check:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 11: ordinal not in range(128)
Summary: [abrt] rpmlint-1.5-5.fc19: TagsCheck.py:490:spell_check:UnicodeDecodeError: '...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f1fcd238921b970c73b097b804f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-30 19:29 UTC by Frank Büttner
Modified: 2013-12-25 02:37 UTC (History)
8 users (show)

Fixed In Version: rpmlint-1.5-6.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-20 01:49:52 UTC


Attachments (Terms of Use)
File: backtrace (1.99 KB, text/plain)
2013-11-30 19:29 UTC, Frank Büttner
no flags Details
File: environ (2.88 KB, text/plain)
2013-11-30 19:29 UTC, Frank Büttner
no flags Details
The problematic rpm file. (272.61 KB, application/octet-stream)
2013-12-01 18:46 UTC, Frank Büttner
no flags Details

Description Frank Büttner 2013-11-30 19:29:40 UTC
Description of problem:
simple call rpmlint to check an package

Version-Release number of selected component:
rpmlint-1.5-5.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python -ttOu /usr/bin/rpmlint 'navit-zubeh\xc3\xb6r-0.5.0-5723.fc19.x86_64.rpm'
executable:     /usr/bin/rpmlint
kernel:         3.11.9-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
TagsCheck.py:490:spell_check:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 11: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/rpmlint", line 378, in <module>
    main()
  File "/usr/bin/rpmlint", line 168, in main
    runChecks(pkg)
  File "/usr/bin/rpmlint", line 228, in runChecks
    check.check(pkg)
  File "/usr/share/rpmlint/TagsCheck.py", line 686, in check
    self.check_summary(pkg, lang, ignored_words)
  File "/usr/share/rpmlint/TagsCheck.py", line 887, in check_summary
    spell_check(pkg, utf8summary, 'Summary(%s)', lang, ignored_words)
  File "/usr/share/rpmlint/TagsCheck.py", line 490, in spell_check
    if uppername in upperword or upperword in upperparts:
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 11: ordinal not in range(128)

Local variables in innermost frame:
upperparts: ['NAVIT', 'ZUBEH\xc3\xb6R', "NAVIT'S", "ZUBEH\xc3\xb6R'S"]
ignored: set(['', 'navit-zubeh\xc3\xb6r', 'share', 'rpmlib(CompressedFileNames)', 'rpmlib(PayloadIsXz)', 'man1', 'libglib-2.0.so.0()(64bit)', 'maptool', 'libc.so.6(GLIBC_2.2.5)(64bit)', 'usr', 'man', 'bin', 'libc.so.6(GLIBC_2.3)(64bit)', 'libc.so.6(GLIBC_2.14)(64bit)', 'libpthread.so.0(GLIBC_2.2.5)(64bit)', 'rpmlib(FileDigests)', 'navit-zubeh\xc3\xb6r(x86-64)', 'libc.so.6(GLIBC_2.3.4)(64bit)', 'libm.so.6(GLIBC_2.15)(64bit)', 'libz.so.1()(64bit)', 'libgmodule-2.0.so.0()(64bit)', 'libm.so.6()(64bit)', 'rtld(GNU_HASH)', 'libgthread-2.0.so.0()(64bit)', 'libc.so.6(GLIBC_2.4)(64bit)', 'rpmlib(PayloadFilesHavePrefix)', 'libc.so.6()(64bit)', 'libpq.so.5()(64bit)', 'maptool.1.gz', 'libpthread.so.0()(64bit)', 'libm.so.6(GLIBC_2.2.5)(64bit)'])
uppername: 'NAVIT-ZUBEH\xc3\xb6R'
lang: 'en_US'
err: <enchant.checker.SpellChecker instance at 0x2a44b00>
warned: set([])
fmt: 'Summary(%s)'
checker: <enchant.checker.SpellChecker instance at 0x2a44b00>
upperword: u'NAVIT'
str: u'Tools for navit'
dict_found: True
x: 'ZUBEH\xc3\xb6R'
ups: ["NAVIT'S", "ZUBEH\xc3\xb6R'S"]
pkg: <Pkg.Pkg instance at 0x27b9560>

Comment 1 Frank Büttner 2013-11-30 19:29:50 UTC
Created attachment 831020 [details]
File: backtrace

Comment 2 Frank Büttner 2013-11-30 19:29:54 UTC
Created attachment 831021 [details]
File: environ

Comment 3 Ville Skyttä 2013-12-01 18:28:17 UTC
What was the package being checked? If it's not in Fedora, could you post an URL to it and possibly upload it somewhere for testing?

Comment 4 Frank Büttner 2013-12-01 18:46:28 UTC
Created attachment 831260 [details]
The problematic rpm file.

I can imagine that, the problem is the special character "ö".
Or can't rpm deal with latin1 characters?

Comment 5 Ville Skyttä 2013-12-01 20:56:12 UTC
rpmlint didn't do the right thing with non-ASCII chars in package names. Fixed upstream: http://sf.net/p/rpmlint/code/ci/9844a91/

Comment 6 Fedora Update System 2013-12-12 19:24:22 UTC
rpmlint-1.5-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rpmlint-1.5-6.fc18

Comment 7 Fedora Update System 2013-12-12 19:24:31 UTC
rpmlint-1.5-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rpmlint-1.5-6.fc19

Comment 8 Fedora Update System 2013-12-12 19:24:41 UTC
rpmlint-1.5-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rpmlint-1.5-6.fc20

Comment 9 lnie 2013-12-13 06:31:24 UTC
1.5-6.fc20 works fine

Comment 10 Fedora Update System 2013-12-13 17:56:28 UTC
Package rpmlint-1.5-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpmlint-1.5-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23341/rpmlint-1.5-6.fc20
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-12-20 01:49:52 UTC
rpmlint-1.5-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-12-25 02:33:54 UTC
rpmlint-1.5-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-12-25 02:37:31 UTC
rpmlint-1.5-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.