Bug 1036311 - Review Request: glite-lbjp-common-gsoap-plugin - Plugin for gSoap to use glite-security-gss as the communication layer
Summary: Review Request: glite-lbjp-common-gsoap-plugin - Plugin for gSoap to use glit...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-30 20:00 UTC by František Dvořák
Modified: 2013-12-24 17:56 UTC (History)
2 users (show)

Fixed In Version: glite-lbjp-common-gsoap-plugin-3.2.10-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-17 19:11:21 UTC
i: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description František Dvořák 2013-11-30 20:00:20 UTC
Spec URL: http://scientific.zcu.cz/fedora/glite-lbjp-common-gsoap-plugin-3.2.10-1/glite-lbjp-common-gsoap-plugin.spec
SRPM URL: http://scientific.zcu.cz/fedora/glite-lbjp-common-gsoap-plugin-3.2.10-1/glite-lbjp-common-gsoap-plugin-3.2.10-1.fc21.src.rpm
Description: glite-security-gsoap-plugin is plugin for gSoap providing secured communication via GSS, as well as strict timing control of all operations via glite-security-gss.
Fedora Account System Username: valtri

Notes:
- I'm upstream maintainer
- koji build: http://koji.fedoraproject.org/koji/taskinfo?taskID=6241436

Comment 1 Christopher Meng 2013-12-02 05:10:30 UTC
I think you should BR krb5-devel.

Have you tested it yet?

Comment 2 František Dvořák 2013-12-02 10:07:35 UTC
Yes, it is well tested. This change is there since January 2012 and used in EGI, http://www.egi.eu/.

In this case, the dependency is globus-gssapi-gsi-devel, and the dependency is provided transitively by glite-lbjp-common-gss-devel package.

Usually I would keep the rule "for each beast what it needs" (and gsoap-plugin needs GSS API), but I think it is better to get it only transitively, because the glite-lbjp-common-gss-devel package providing security can have different dependency based on the build options (globus providing proxy certificate, or krb5 providing Kerberos mechanism).

Comment 3 Christopher Meng 2013-12-05 11:36:18 UTC
1 .Only some warnings:

glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 namespaces
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_faultstring
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_getheader
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_faultcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_faultdetail
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_putelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_putfault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_getelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_serializefault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_serializeheader
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_markelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_putheader
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_check_faultdetail
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_faultsubcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_getfault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_c.so.9.2.10 soap_check_faultsubcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 namespaces
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_faultstring
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_getfault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_serializefault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_getelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_putfault
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_check_faultdetail
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_faultdetail
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_faultsubcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_markelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_getheader
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_serializeheader
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_check_faultsubcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_faultcode
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_putelement
glite-lbjp-common-gsoap-plugin.i686: W: undefined-non-weak-symbol /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 soap_putheader
glite-lbjp-common-gsoap-plugin.i686: W: unused-direct-shlib-dependency /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 /lib/libm.so.6
glite-lbjp-common-gsoap-plugin.i686: W: unused-direct-shlib-dependency /usr/lib/libglite_security_gsoap_plugin_2816_cxx.so.9.2.10 /lib/libgcc_s.so.1

Hope you can fix them being as the upstream.

2. devel subpackage can %doc examples/

3. prefix=@PREFIX@
exec_prefix=${prefix}
libdir=/usr/@LIBDIR@
includedir=${prefix}/include

Ah, libdir can be libdir=${prefix}/@LIBDIR@ or just libdir=@LIBDIR@ and pass --libdir=%{_libdir} instead of --libdir=%{_lib} during configure.

But these are not issues, just hints.

--------SO--------

PACKAGE APPROVED.

Comment 4 František Dvořák 2013-12-06 16:05:06 UTC
Thanks for the hints and review!

1. this would be problem to solve:
1a) the missing symbols: they will be available in the gsoap-plugin "client" code, they are part of the gsoap generated stub code and may be specific to used web service interface
1b) unused library dependencies: additional libraries go from the linker used by c++

2. good idea, examples added

3. fixed, in gsoap-plugin and in other packages :-): https://github.com/CESNET/glite-lb/commit/bda0b2176a3f7efee53da4bab564dfc3308e1cd7 , it will be included in the next release

Spec URL: http://scientific.zcu.cz/fedora/glite-lbjp-common-gsoap-plugin-3.2.10-2/glite-lbjp-common-gsoap-plugin.spec
SRPM URL: http://scientific.zcu.cz/fedora/glite-lbjp-common-gsoap-plugin-3.2.10-2/glite-lbjp-common-gsoap-plugin-3.2.10-2.fc21.src.rpm

Comment 5 František Dvořák 2013-12-06 16:07:57 UTC
New Package SCM Request
=======================
Package Name: glite-lbjp-common-gsoap-plugin
Short Description: Plugin for gSoap to use glite-security-gss as the communication layer
Owners: valtri
Branches: f18 f19 f20 el6
InitialCC:

Comment 6 Gwyn Ciesla 2013-12-06 18:43:27 UTC
Git done (by process-git-requests).

Comment 7 Fedora Update System 2013-12-07 12:36:46 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/glite-lbjp-common-gsoap-plugin-3.2.10-2.fc20

Comment 8 Fedora Update System 2013-12-07 12:38:45 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/glite-lbjp-common-gsoap-plugin-3.2.10-2.fc19

Comment 9 Fedora Update System 2013-12-07 12:39:38 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/glite-lbjp-common-gsoap-plugin-3.2.10-2.fc18

Comment 10 Fedora Update System 2013-12-07 12:40:37 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/glite-lbjp-common-gsoap-plugin-3.2.10-2.el6

Comment 11 Fedora Update System 2013-12-07 18:47:02 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc20 has been pushed to the Fedora 20 testing repository.

Comment 12 Fedora Update System 2013-12-16 22:57:22 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc19 has been pushed to the Fedora 19 stable repository.

Comment 13 Fedora Update System 2013-12-16 23:05:18 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc18 has been pushed to the Fedora 18 stable repository.

Comment 14 Fedora Update System 2013-12-17 19:11:21 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.fc20 has been pushed to the Fedora 20 stable repository.

Comment 15 Fedora Update System 2013-12-24 17:56:28 UTC
glite-lbjp-common-gsoap-plugin-3.2.10-2.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.