Bug 103653 - up2date loops forever
up2date loops forever
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Steve Salevan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 11:39 EDT by Mark Post
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version: 3U9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 11:58:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Post 2003-09-03 11:39:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
With the September 02, 2003 updates, up2date will loop forever until
interrupted.  The sequence of steps I took is:
/usr/sbin/up2date-nox -l
I took the list of updates, and put them into a file, then
cat rpmlist | xargs /usr/sbin/up2date-nox -f -d

The output I get is this:
Fetching package list for channel: rhel3-beta1-as-i386...
########################################

Fetching Obsoletes list for channel: rhel3-beta1-as-i386...

Testing package set / solving RPM inter-dependencies...
########################################
anaconda-9.0.6-0.RHEL.20030 ########################## Done.
anaconda-runtime-9.0.6-0.RH ########################## Done.
arts-1.1.3-2.1.i386.rpm:    ########################## Done.
-snip long list of updates-
wireless-tools-26-2.i386.rp ########################## Done.
xscreensaver-4.10-4.i386.rp ########################## Done.
xterm-179-4.i386.rpm:       ########################## Done.

Fetching Obsoletes list for channel: rhel3-beta1-as-i386...

Testing package set / solving RPM inter-dependencies...
########################################
up2date-3.9.23-1.i386.rpm:  ########################## Done.
up2date-gnome-3.9.23-1.i386 ########################## Done.
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
up2date-gnome                           3.9.23         1

Restarting up2date

Fetching package list for channel: rhel3-beta1-as-i386...
########################################

Fetching Obsoletes list for channel: rhel3-beta1-as-i386...

Testing package set / solving RPM inter-dependencies...
########################################
anaconda-9.0.6-0.RHEL.20030 ########################## Done.
anaconda-runtime-9.0.6-0.RH ########################## Done.
arts-1.1.3-2.1.i386.rpm:    ########################## Done.
arts-devel-1.1.3-2.1.i386.r ########################## Done.
aumix-2.8-6.EL.i386.rpm:    ########################## Done.
-snip logn list of updates-
wireless-tools-26-2.i386.rp ########################## Done.
xscreensaver-4.10-4.i386.rp ########################## Done.
xterm-179-4.i386.rpm:       ########################## Done.

Fetching Obsoletes list for channel: rhel3-beta1-as-i386...

Testing package set / solving RPM inter-dependencies...
########################################
up2date-3.9.23-1.i386.rpm:  ########################## Done.
up2date-gnome-3.9.23-1.i386 ########################## Done.
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
up2date-gnome                           3.9.23         1

Restarting up2date

Fetching package list for channel: rhel3-beta1-as-i386...
########################################

Fetching Obsoletes list for channel: rhel3-beta1-as-i386...

Testing package set / solving RPM inter-dependencies...
########################################
anaconda-9.0.6-0.RHEL.20030 ########################## Done.
anaconda-runtime-9.0.6-0.RH ########################## Done.
arts-1.1.3-2.1.i386.rpm:    ########################## Done.
arts-devel-1.1.3-2.1.i386.r ########################## Done.
aumix-2.8-6.EL.i386.rpm:    ########################## Done.
cpp-3.2.3-17.i386.rpm:      ########################## Done.


And on, and on, and on.

Version-Release number of selected component (if applicable):
up2date-3.9.12-1

How reproducible:
Always

Steps to Reproduce:
1.See above
2.
3.
    

Actual Results:  See above

Expected Results:  I would have expected up2date to run through the list once,
download all the files, and then quit.

Additional info:
Comment 1 Bill Nottingham 2003-09-03 12:21:35 EDT

*** This bug has been marked as a duplicate of 102966 ***
Comment 2 Adrian Likins 2003-09-03 16:50:00 EDT
this is not a dup of  102966 as best I can tell
Comment 3 Adrian Likins 2003-09-03 16:52:26 EDT
>The sequence of steps I took is:
>/usr/sbin/up2date-nox -l
>I took the list of updates, and put them into a file, then
>cat rpmlist | xargs /usr/sbin/up2date-nox -f -d

This tells up2date to download (and _not_ install) the
package specified, and its deps. So no packages are ever
installed, and the rpm database is not changed. 

So every time you run it, it downloads any new
packages it needs (it will display a progress
bar indicating it is getting already downloaded
packages, but will zip to 100%). 

This doesnt look like a bug to me. Am I
missing something?
Comment 4 Mark Post 2003-09-03 17:00:28 EDT
Yes, you are.  :)  I did _not_ reissue the up2date command.  The 
problem is that up2date restarts itself, and does the whole 
thing, over and over and over again.  It will never stop unless 
a cntl-c is issued.  While this was going on, I fired up top to 
see what kind of system resources it was using: 96% of one of my 
two processors, or about 48% of my entire system.
Comment 5 Adrian Likins 2003-09-03 17:43:44 EDT
ah, I see. 

First guess is that the commandline "-d" is overriding
the stuff to install up2date, and just installs it
instead. That would cause looping like you
mention. 

Fix is probabaly to disable the auto up2date up2date
in cases where -d is installed (current policy
is basically to only install the new up2date if
doing something that would install packages
[aka, `up2date foobar` or `update -u`]. 

I'll take a look and try to get this into
3.9.24 or so. I'll update the report when I
build a version with a fix. 
Comment 6 Adrian Likins 2003-09-04 21:28:12 EDT
should be fixed in 3.9.24 
Comment 7 Steve Salevan 2007-06-21 11:58:16 EDT
Looks good on both 4U5 and 3U9.  This bug is CLOSED, CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.