Bug 10367 - Another installer python traceback (different)
Another installer python traceback (different)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-27 01:46 EST by Andy McLaughlin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-12 14:28:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy McLaughlin 2000-03-27 01:46:45 EST
Hi, I don't think I've seen this one yet.  It is SIMILAR to the tracebacks
listed in the gotchas:
http://www.redhat.com/support/docs/gotchas/6.1/gotchas-6.1-4.html#ss4.15
and in bugs:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=7879
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=9607

I am installing using the official RH CD.  I have updated the boot floppy
image as per the gotchas, and the python update.  I insert the update when
prompted and proceed through all of the questions.  I previously had
the "unsubscriptable object" (or something like that) traceback which seems
to be fixed now.  This traceback occurs prior to installing packages,
immediately after the installer builds the package list or something, after
formatting the swap partition, and after detecting my video card.

Here is the latest traceback:

File "/usr/bin/anaconda", line 227,
in ?
  intf.run(todo, test = test)
File
"/usr/lib/python1.5/site-packages/text.py", line 1009, in run
  rc = apply (step[1](), step [2])
File
"/usr/lib/python1.5/site-packages/text.py", line 572, in __call__
  if todo.doInstall():
File
"/usr/lib/python1.5/site-packages/todo.py", line 1477, in doInstall
  db = rpm.opendb (1, self.instPath)
rpm.error: cannot open

Crash-ola.  There is also another error message which is obscured by the
traceback "window", and it looks like this:
Cannot [THIS PART IS OBSCURED] tsindex.rpm: Invalid argument

If I use the GUI instead, it simply hangs at approximately the same point.
I don't know how to see any error messages it might be producing.

I'm using an AMD K6/200, Award BIOS, generic S3 Trio video, no sound, 2G
Maxtor HDD (primary master) + .5G Fujitsu (primary slave), 96M RAM.  This
machine was running Red Hat 5.2 previously, without any difficulty.

<rant>
I am a computer professional.  I just spent several years in Silicon Valley
working as a system administrator, then as a programmer.  I have spent the
entire weekend staring at various versions of this Red Hat installer.  It
has been a complete waste of time.  I tell you this: if I can't install Red
Hat Linux, then no one else that I know (personally) can do it either.  My
Mom sure can't, which means that Red Hat Linux will never replace MS
Windows on her desktop (if it weren't for Windows 98, I wouldn't be able to
submit this bug report because my Linux machine is now hosed).  I think
that Red Hat is doing the Linux community a disservice by publishing this
installer.  This is poor, poor, sloppy software IMHO.  My brother thinks I
should use Mandrake.  Unfortunately, I must use Red Hat since my employer
insists on it.

I have tried many combinations, including FTP attempts from 3 different
servers, trying RH6.0 and 6.1, hard disk installs of both versions, and
today I finally gave in and bought the "official" Red Hat CD which I can't
seem to use either, officially.

Yesterday, I was trying to find a workaround, and I chose the "Server
Install" by mistake.  Before my fingers could reach CTRL-ALT-DEL the
installer began reformatting my /home filesystem, without prompting me.
Thanks, Red Hat.
</rant>

Please let me know if there is a workaround for this, because I need to use
this machine for work.
Comment 1 Jay Turner 2000-04-24 08:26:59 EDT
Forwarding this issue to a developer for further action.

As a side note, have you tried out latest installer to see whether it exhibits
the same behavior?  We just recently released Red Hat Linux 6.2, and the
installer present in the 6.1 release is really shored up in the 6.2 release.
Comment 2 Michael Fulbright 2000-06-12 14:28:55 EDT
There are confirmation windows in the latest development version to confirm
before proceeding with an install or upgrade.

Note You need to log in before you can comment on or make changes to this bug.