Bug 103689 - tclConfig.sh contains faulty values
tclConfig.sh contains faulty values
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: tcltk (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 17:26 EDT by Joshua Ginsberg
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 22:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Ginsberg 2003-09-03 17:26:45 EDT
Hello -

I've been trying to build AOLServer 3.5 and 4.0b over the last few days, and
there have been numerous compile time errors because of values sought in
tclConfig.sh that were not there. I'm told they are there when compiling tcl
from source.

First, your tcl package is compiled with threads; I've checked by looking at the
spec file in the src rpm. This should result in TCL_THREADS=1 in tclConfig.sh

Second, TCL_CC_SEARCH_FLAGS is not set which programs compiling against TCL
require. I'd imagine an appropriate value would be -L but I could be wrong.

c.f.
http://sourceforge.net/tracker/index.php?func=detail&aid=799548&group_id=3152&atid=103152

Thanks!

-jag
Comment 1 Joshua Ginsberg 2003-09-03 19:37:08 EDT
Additionally:

TCL_LIBS should include -lpthread
TCL_SHLIB_LD should include -nostartfiles

I think.

-jag
Comment 2 Jens Petersen 2003-09-18 04:52:23 EDT
I wonder why the tclConfig.sh file isn't being setup properly?

Nothing special is being done to tclConfig.sh in our build - it
should be automatically generated from tclConfig.sh.in when
configure is run.  So I don't see the above variables should get
set...

I don't see any mention of TCL_CC_SEARCH_FLAGS in tcl-8.3.5.

I wonder why configure isn't adding -lpthread if its needed,
but since tcl isn't being built with --enable-threads,
I'm not sure if it should be set.

Why should -nostartfiles be added to TCL_SHLIB_LD?
Comment 3 Joshua Ginsberg 2003-09-18 05:48:21 EDT
I couldn't tell you for sure.

All I know is that I can't compile AOLServer with the TCL provided with RH9 yet
I can with a pure compile of TCL from tcl.tk; it seems to me like I should be
able to compile with the RH9 distro version.

IIRC, when I downloaded the src.rpm from RH8 (a while ago before RH9) I looked
at the spec file which had the --enable-threads flag set during configure. Why
wouldn't you compile with threads?

I'd recommend that you c.f the sf.net link and speak with the experts on
AOLServer. Given that RH now owns ArsDigita which based much of its code on
AOLServer, it would seem that RH would want to be able to compile easily with
AOLServer.

-jag
Comment 4 Jens Petersen 2004-02-26 01:57:56 EST
Any better with the tcl-8.4.5 packages in FC/devel (rawhide)
currently?

Note You need to log in before you can comment on or make changes to this bug.