Bug 103691 - Anacron missing
Summary: Anacron missing
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: dff
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-03 21:45 UTC by Brian Long
Modified: 2007-11-30 22:06 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 17:28:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Long 2003-09-03 21:45:58 UTC
Description of problem:
Anacron is a useful program on enterprise always-on servers.  When you schedule
downtime on an enterprise always-on server, you want to be able to rely on
anacron running the cron jobs you missed during the downtime.  Not including
anacron in taroon is not acceptable.  Please add it back.  Thanks.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Tom "spot" Callaway 2003-09-03 22:01:44 UTC
FWIW, I agree with this.

Comment 2 Dax Kelson 2003-09-03 23:12:12 UTC
Strongly Agreed. Please put it back.

Also, if you are going to remove some package common courtesy dictates that you
mark it deprecated for one distro release, and THEN remove it.

Comment 3 Daniel Wittenberg 2003-09-03 23:56:40 UTC
Agreed on both comments.

Comment 4 Josiah Royse 2003-09-04 12:45:28 UTC
Anacron is useful.

Comment 5 Brian Long 2003-09-04 18:58:02 UTC
The argument was given that anacron is not needed on enterprise, always-on
servers.  That argument cannot hold water when you consider anaconda was removed
from the Taroon WS beta as well.  3.0WS installations will be on workstation
machines, not enterprise, always-on machines.  anacron needs to be added back to
taroon, period.

Comment 6 Joshua Jensen 2003-09-04 19:26:02 UTC
*IF* the machine is always on, then we won't run anacron, and including it won't
hurt anything.  However if the IF turns out to not always be true, then we
honestly need it.  Red Hat need not shoot itself in this way.

Comment 7 John Haxby 2003-10-29 15:58:47 UTC
It's perfectly reasonable to run Taroon WS on a laptop which is definitely not
"always on".   Actually, I run Taroon ES on a laptop since I need some of the
server packages that are not otherwise present.   Anacron on a laptop is not so
much a good idea as an out and out requirement.

Please put it back.

Comment 8 M Jang 2004-01-07 18:38:01 UTC
anacron is also listed as part of the RH133 course, which is labeled 
as "Updated for building skills on Red Hat Enterprise Linux 3!"

Comment 9 Steve Bonneville 2004-01-09 03:30:21 UTC
The information at
http://www.redhat.com/training/rhce/courses/rh133_content.html has not
yet been updated to reflect the Red Hat Enterprise Linux 3 changes to
the curriculum.  The appropriate folks will be notified that that page
still needs to be updated.  I believe that anacron coverage was
dropped for now since it is not shipped with RHEL 3.  (I'd like to see
anacron come back as well.)

Comment 10 Suzuki Takashi 2004-07-24 07:45:48 UTC
According to the information at the page 
http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/step-
guide/s1-managing-locating.html, 
we CAN run anacron and MUST refer to the man page on anacron. 
But we have no anacron package in the installation CD, nor can we get 
the ones through the RHN channel.


Comment 11 dff 2004-07-29 20:53:23 UTC
Anacron will be added in RHEL 3 Update 3.  A beta package is now
available to RHEL subscribers for testing via Red Hat Network:

https://rhn.redhat.com/network/software/packages/details.pxt?pid=248606

Comment 12 Brian Long 2004-08-02 12:24:03 UTC
Thank you!


Note You need to log in before you can comment on or make changes to this bug.