Bug 103698 - rpmdb corruption can cause the system not to boot wrt, mkkerneldoth
rpmdb corruption can cause the system not to boot wrt, mkkerneldoth
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-03 18:54 EDT by Need Real Name
Modified: 2014-03-16 22:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 17:57:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-09-03 18:54:22 EDT
Description of problem:
corruption of rpm-db can lead to an unbootable system
wrt. /sbin/mkkerneldoth

at line 765 of /etc/rc.d/rc.sysinit /sbin/mkkerneldoth
is called. in my case there was rpm-db corruption which
lead to rpm -q hanging and in return the system, becoming 
unresponsive.

Version-Release number of selected component (if applicable):
initscripts-7.14-1

How reproducible:

Steps to Reproduce:
1. corrupt your rpmdb
2. boot
3. watch it hang
    
Actual results:
system hang's after 'Enabling swap partitions [OK]'
no information is given as to where the problem is.

Expected results:
the system booting, or at least some mention of where
the problem is. 

Additional info:
Comment 1 Bill Nottingham 2005-01-21 17:57:25 EST
mkkerneldoth is not used in current (FC2+, RHEL4+) systems.

Not sure how one can detect that the rpm database is corrupted to
avoid this problem.

Note You need to log in before you can comment on or make changes to this bug.