Bug 103798 - httpd failed after up2date
httpd failed after up2date
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-04 22:16 EDT by Ron MacDonald
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-05 03:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron MacDonald 2003-09-04 22:16:53 EDT
Description of problem:
After running up2date to fix vulnerabilities with httpd, the update stated it 
was successful.  However, I had the following errors:
file /usr/lib/httpd/modules/mod_include.so from install of httpd-2.0.40-11.7 
conflicts with file from package httpd-2.0.40-11.5
file /usr/lib/httpd/modules/mod_proxy_ftp.so from install of httpd-2.0.40-11.7 
conflicts with file from package httpd-2.0.40-11.5
file /usr/lib/httpd/modules/mod_rewrite.so from install of httpd-2.0.40-11.7 
conflicts with file from package httpd-2.0.40-11.5
file /usr/lib/libaprutil.so.0.0.0 from install of httpd-2.0.40-11.7 conflicts 
with file from package httpd-2.0.40-11.5
file /usr/sbin/httpd from install of httpd-2.0.40-11.7 conflicts with file from 
package httpd-2.0.40-11.5
file /usr/sbin/suexec from install of httpd-2.0.40-11.7 conflicts with file 
from package httpd-2.0.40-11.5
file /usr/share/man/man1/logresolve.1.gz from install of httpd-2.0.40-11.7 
conflicts with file from package httpd-2.0.40-11.5
file /usr/share/man/man8/httpd.8.gz from install of httpd-2.0.40-11.7 conflicts 
with file from package httpd-2.0.40-11.5

Now I am unable to run my web services.  Any ideas on how I can fix, undo the 
update and get my web services running again?  Thanks in advance,

Ron Macdonald

Version-Release number of selected component (if applicable):
httpd-2.0.40-11.7

How reproducible:
1./usr/sbin/httpd -k stop, start, gracefully
2.up2date
3.rpm -Uvh <httpd.rpms>
    
Actual results:
states service has started.  Run ps -auxw | grep httpd
httpd is not running, users cannot connect to web.

Expected results:
The update should have been smooth like previous updates for httpd.

Additional info:
would like to see rpm's have the ability to backout from the install if 
problems are experienced during update and automatically return to original 
configuration. I'm tired of reinventing the wheel after updates.
Comment 1 Joe Orton 2003-09-05 03:56:12 EDT
Why are you running 

 rpm -Uvh <httpd.rpms>

after the up2date?  I would expect this to fail as you describe - running
up2date is sufficient to get the updated httpd packages.

Note You need to log in before you can comment on or make changes to this bug.