Bug 103803 - rhn_register fails with SSL_CONNECT problems when attempting to change the registration of a previously registered system.
Summary: rhn_register fails with SSL_CONNECT problems when attempting to change the re...
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-05 05:31 UTC by Rich
Modified: 2015-01-08 00:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 18:47:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rich 2003-09-05 05:31:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4b) Gecko/20030605
Mozilla Firebird/0.6

Description of problem:
I borrowed a old laptop from a friend for another friend who just got out of the
hospital to read email on.  I could not do up2date because his registration had
expired.  I attempted to run rhn_register to reregister the system under my
name, and I lost.  SSL_CONNECT errors.  I saw the note about the cert change, so
I download the the new rpms, and no joy.  Still it starts says this system is
already registered do you want to proceed.  I say yes, and then it dies with 5
SSL_CONNECT failures.  I verify the new cert, and the rpm files and they are all
good.  Still no joy.  I lose.

Finally I gave up renamed the /etc/sysconfig/rhn/{rhn_register,systemid} files
and run rhn_register.  Now I have joy. My system is updated, thought you might
want to know about the bug. 

Version-Release number of selected component (if applicable):
1.7.3

How reproducible:
Always

Steps to Reproduce:
1.take a system with an expired registration, i.e. one that has been unused for
months.
2. run rhn_register to change the registration to a new account
3. Click yes when it asks if you want to do so.
Voila!  

Actual Results:  5 SSL_CONNECT failures.  A note saying server or certificate
error.  No joy.

Expected Results:  It should have allowed me to reset the registration information.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.