Bug 103858 - RFE: please add niash (ScanJet 3300C among others) support
RFE: please add niash (ScanJet 3300C among others) support
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: sane-backends (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://sourceforge.net/projects/hp330...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-05 15:57 EDT by Simon Karpen
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 12:42:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Karpen 2003-09-05 15:57:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The HP Scanjet 3300C, 3400C, and 3500C, as well as one agfa scanner, use  the
"niash" chipset. 

There is an open source SANE backend for them, but it's not part of the core
SANE distribution yet. It appears to only support color right now (tested under
xsane), but otherwise works pretty acceptably.

The URL is http://sourceforge.net/projects/hp3300backend, and there's more
background information at http://home.kabelfoon.nl/~bertrik/hp3300c/hp3300c.html. 

The patch (included in the "testtool" distribution off of sourceforge) is a
shell script that edits a few makefiles and adds several files to the SANE
distribution. Adding it as part of the %prep should work. 


Version-Release number of selected component (if applicable):
sane-backends-1.0.12-3

How reproducible:
Always

Steps to Reproduce:
1. RFE
2. not a bug
3. try unpatched SANE backends with a HP 3300C
    

Additional info:
Comment 1 Tim Waugh 2003-09-09 12:42:57 EDT
The best thing would be for that backend to be integrated into the sane-backends
upstream package.

Note You need to log in before you can comment on or make changes to this bug.