Bug 103887 - rhn-applet-tui crash at first lauch
rhn-applet-tui crash at first lauch
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: rhn-applet (Show other bugs)
beta1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-06 05:14 EDT by Féliciano Matias
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-03 10:39:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Féliciano Matias 2003-09-06 05:14:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
rhn-applet-tui crash at first lauch.

Version-Release number of selected component (if applicable):
rhn-applet-2.0.10-4

How reproducible:
Always

Steps to Reproduce:
$ rm -f .rm -f .rhn-applet.c*
$ rhn-applet-tui

Actual Results:
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-tui", line 103, in ?
    main(original_arg_list)
  File "/usr/bin/rhn-applet-tui", line 65, in main
    ignored_package_str = rhn_utils.get_user_config("IgnoredPackages")
  File "/usr/bin/../share/rhn/rhn_applet/rhn_utils.py", line 95, in get_user_config
    user_config_obj.init()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_utils.py", line 78, in init
    self.save()
  File "/usr/share/rhn/up2date_client/config.py", line 186, in save
    f.write("%s[comment]=%s\n" % (key, val[0]))
UnicodeError: ASCII encoding error: ordinal not in range(128)


Expected Results:  No crash

Additional info:
next tries are ok.
Comment 1 raxet 2003-09-07 00:30:40 EDT
If I do a rm -f .rm -f .rhn-applet.c*, then a rhn-applet-tui

I get the same here, but rather if I execute rhn-applet-gui the following error
appears:

 rhn-applet-gui
Traceback (most recent call last):
  File "/usr/bin/rhn-applet-gui", line 41, in ?
    main()
  File "/usr/bin/rhn-applet-gui", line 37, in main
    applet = rhn_applet.rhnApplet()
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 143, in __init__
    self.session = gnome.ui.gnome_master_client()
AttributeError: 'module' object has no attribute 'gnome_master_client'
Comment 2 Daniel Veillard 2003-09-07 05:50:41 EDT
raxet, you're mixing problems, yours is a duplicate of #103871, go there
for the solution.

The problem of this bug report is UTF8 localized strings being
casted to ASCII, and I guess related to the new translated strings 
when operating in the French locales.

Daniel
Comment 3 Féliciano Matias 2003-09-07 15:51:42 EDT
> when operating in the French locales.

I miss this point. The problem append with LANG=fr_FR.UTF-8 but not with
en_GT.UTF-8 or C.
Comment 4 Daniel Veillard 2003-09-07 16:38:51 EDT
Bingo ... I guessed without testing :-)

Simply because with LANG=fr_FR.UTF-8 the translated string uses non-ascii
character, and that not the case for "en" or "C".
The problem is a conversion from an internationalized string to an ASCII
string. Python raises an exception, I need to get it converted ...

Daniel
Comment 5 Féliciano Matias 2003-09-11 16:08:38 EDT
It appeart to be fixed in rhn-applet-2.0.10-6.
Tested with LANG=fr_FR.UTF-8 and LANG=C.
Comment 6 Féliciano Matias 2004-04-03 10:39:33 EST
Fixed in FC2 T2.

Note You need to log in before you can comment on or make changes to this bug.