Bug 103889 - mod_perl SRPM build enhancements
Summary: mod_perl SRPM build enhancements
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mod_perl (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Gary Benson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-06 13:10 UTC by Ville Skyttä
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 09:24:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2003-09-06 13:10:31 UTC
Building mod_perl 1.99_09-8 in Rawhide emits a big warning about gdbm stuff
during build, adding BuildRequires: gdbm-devel would make it go away.  I'm not
100% sure if it's needed though.

Also, when building the SRPM as non-root, stripping fails because various *.so
are installed with 0444 perms.  Adding this to the end of the %install section
would fix it:

   find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | xargs chmod u+w


Note You need to log in before you can comment on or make changes to this bug.