Bug 103896 - xchat won't remember the correct screen position it was
xchat won't remember the correct screen position it was
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: xchat (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-06 15:04 EDT by Alexandre Oliva
Modified: 2007-04-18 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.0.4-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-19 02:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (extracted from current CVS), fixing this for me. (1.34 KB, patch)
2003-09-10 16:05 EDT, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2003-09-06 15:04:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After I subscribed to the Severn-updates channel and continuously installed all
available updates, which started some time early this week, xchat wouldn't
reopen on the same screen position it was when I last closed it.  Instead, the
position it chooses seems to be offset by the exact amount of space taken by the
window manager windows borders and the top bar.  I.e., every time I start it, it
moves down one row and right a few pixels.  This is somewhat annoying, and
didn't happen before the updates.  I can't tell whether the problem is in the
window manager or xchat proper, so I included version numbers for both.

Version-Release number of selected component (if applicable):
xchat-2.0.4-2 metacity-2.5.3-3

How reproducible:
Always

Steps to Reproduce:
1.start xchat
2.place a marker on the upper-left corner somehow (say, another window)
3.close xchat
4.open it again

Actual Results:  the position will be off: the window manager border's
upper-left corner will be where the application's upper-left corner used to be

Expected Results:  it should come back at the same location it was before it was
closed, like it did before the updates

Additional info:
Comment 1 Mike A. Harris 2003-09-09 08:13:18 EDT
Added WM maintainers to CC list in case they're aware of any WM related
problems.  I'm unable to reproduce with my system.
Comment 2 Miloslav Trmac 2003-09-10 16:05:32 EDT
Created attachment 94387 [details]
Patch (extracted from current CVS), fixing this for me.
Comment 3 Mike A. Harris 2003-09-19 02:37:12 EDT
Patch applied to 2.0.4-3 and confirmed by aoliva via IRC to fix the problem.
Also built for Taroon as 2.0.4-3.EL

Thanks for the patch Miloslav.

Note You need to log in before you can comment on or make changes to this bug.