Bug 103905 - tripwire segmentation fault
tripwire segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: tripwire (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-06 21:03 EDT by Keith Nelson
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 10:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Nelson 2003-09-06 21:03:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Only since latest 7.3 2.96-113 kernel update, on a fully up2date 7.3 i686 
system, tripwire has died with Segmentation Fault. I tried reinstall, upgrade 
etc etc but has same result:
tripwire --init               
Parsing policy file: /etc/tripwire/tw.pol
Generating the database...
*** Processing Unix File System ***
Software interrupt forced exit: Segmentation Fault

Version-Release number of selected component (if applicable):
tripwire-2.3.1-10 plus 2.3.1-14/17/47

How reproducible:
Always

Steps to Reproduce:
1. up2date -u your 7.3 system
2. tripwire --init OR              
3. tripwire --check            
    

Actual Results:  Segmentation Fault

Expected Results:  Performing integrity check...
then normal tripwire report.

Additional info:
Comment 1 Keith Nelson 2003-09-06 21:05:39 EDT
Additional Info: Rebuilt from sources for all versions listed, with same result.
Comment 2 Mark J. Cox (Product Security) 2003-12-12 04:06:29 EST
Have you tried this again on a newer distribution or with all errata
updates applied?
Comment 3 Keith Nelson 2003-12-13 08:40:33 EST
Hi Mark,
   Yes my RH7.3 system has all errata applied, including kernel. 
Unfortunatly the same problem. Currently installed: tripwire 2.3.1 10 
Build Date: Tue 26 Feb 2002 03:11:18 PM PST  however have tried later 
versions with same result.
Comment 4 Mark J. Cox (Product Security) 2004-05-11 04:25:42 EDT
Moving to RHEL2.1 which may be affected by this issue
Comment 5 Mark J. Cox (Product Security) 2004-06-18 13:53:31 EDT
We've just done a tripwire rebuild to fix a possible security flaw for
RHEL2.1: http://rhn.redhat.com/errata/RHSA-2004-244.html
Comment 6 Mark J. Cox (Product Security) 2004-07-14 10:14:55 EDT
Since RHEL7.3 is end of life and we issued this tripwire rebuild I'm
going to close the bug.  Please reopen it if necessary.

Note You need to log in before you can comment on or make changes to this bug.