Bug 103928 - control-center miss audio and proxy icons
control-center miss audio and proxy icons
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: control-center (Show other bugs)
beta1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-07 17:45 EDT by Féliciano Matias
Modified: 2013-04-02 00:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-09 15:53:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (71.49 KB, image/png)
2003-09-08 17:25 EDT, Féliciano Matias
no flags Details

  None (edit)
Description Féliciano Matias 2003-09-07 17:45:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
control-center miss audio and proxy icons.

This can be state only if nautilus is not runnig.

Unlike nautilus, control-center don't use theme icons.

Version-Release number of selected component (if applicable):
control-center-2.3.5-2

How reproducible:
Always

Steps to Reproduce:
1- Verify that nautilus is not renning.
2- launch gnome-control-center.
Comment 1 Jonathan Blandford 2003-09-08 15:25:25 EDT
What do you mean by it misses the audio and proxy icons?  What's 'it' in this
case?  Can you take a screenshot?
Comment 2 Féliciano Matias 2003-09-08 17:25:02 EDT
Created attachment 94315 [details]
screenshot
Comment 3 Féliciano Matias 2003-09-08 17:28:04 EDT
> What do you mean by it misses the audio and proxy icons?

Example :
$ strace -e trace=access gnome-control-center 2>&1 | egrep "(audio)|(globe)"
access("/usr/share/control-center-2.0/icons/gnome-audio.png", F_OK) = -1 ENOENT
(No such file or directory)
access("/usr/share/pixmaps/gnome-audio.png", F_OK) = -1 ENOENT (No such file or
directory)
access("/usr/share/control-center-2.0/icons/gnome-globe.png", F_OK) = -1 ENOENT
(No such file or directory)
access("/usr/share/pixmaps/gnome-globe.png", F_OK) = -1 ENOENT (No such file or
directory)
Comment 4 Féliciano Matias 2003-09-08 17:32:50 EDT
Sorry, i forgot to set priority and severity.
Comment 5 Jonathan Blandford 2003-09-09 15:53:19 EDT
ah!  you mean in the shell.  This shell is basically unsupported in favor of
nautilus and the menus.  It looks like it's not looking in the icon spec as a
backup for the control-cneter icons.  Filed upstream as:
http://bugzilla.gnome.org/show_bug.cgi?id=121859
Comment 6 Féliciano Matias 2003-09-09 18:39:27 EDT
> ah!  you mean in the shell.

From the menu there is the same problem. It's only append if nautilus is not
running.

This don't append with nautilus because nautilus use theme icons. For example if
i launch gnome-control-center (with a shell :-)) and nautilus is running,
nautilus use  /usr/share/icons/Bluecurve/48x48/apps/gnome-globe.png from 
redhat-artwork (If bluecurve is the current theme) and
/usr/share/icons/gnome/48x48/apps/gnome-audio.png from gnome-icon-theme package
because there is no gnome-audio.png in bluecurve theme.

There is two bugs :
- control-center miss audio et proxy icons.
- control-center don't use theme icons.

Note You need to log in before you can comment on or make changes to this bug.