Bug 1039316 - cannot control cursor size anymore
Summary: cannot control cursor size anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mate-themes
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wolfgang Ulbrich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-07 23:30 UTC by jonathan baron
Modified: 2013-12-19 20:36 UTC (History)
4 users (show)

Fixed In Version: mate-themes-1.6.3-0.2.git52ee204.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-19 07:19:56 UTC


Attachments (Terms of Use)

Description jonathan baron 2013-12-07 23:30:07 UTC
Description of problem:

Cannot control cursor size.

Version-Release number of selected component (if applicable):

1.6.2-0.12 (but I'm not sure the problem is here)

How reproducible:

totally

Steps to Reproduce:
1. set cursor size in dconf-editor
2. try to set cursor size in mate-appearance-properties
3.

Actual results:

dconf-editor setting has no effect

setting in mate-appearance-properties is grayed out

Expected results:

I had managed somehow to get a cursor that I could see without a microscope (on a reasonably high-resolution monitor, but not the highest). This setting disappeared and I could not get it back. I'll keep trying.

Additional info:

Why do all these desktops have to depart from the old unix style of text-based configurations? Now it seems that there are several ways of controlling anything, and, at any given time, 0 to 25% of them work.

Comment 1 jonathan baron 2013-12-08 00:06:21 UTC
I finally got it to work. I don't know if all this is necessary, but here is what I did.

Open mate-control-center.

Click on Appearance. (This is the same as mate-appearance-properties, but I tried that and it didn't work.)

Click on Customize (without doing anything else).

Select Pointer.

Choose dmz-aa.

Open dconf-editor. Go to org/mate/desktop/peripherals/mouse

Enter the desired size (48 on one machine for me, 42 on another)

Close dconf-editor and close all the other stuff.

Probably in the course of doing this, I said something, which turned out to be the magic words to get it to work, but I forgot what they were.

WHY IS THIS SO HARD?

Comment 2 Fedora Update System 2013-12-08 18:44:04 UTC
mate-themes-1.6.3-0.2.git52ee204.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-themes-1.6.3-0.2.git52ee204.fc18

Comment 3 Fedora Update System 2013-12-08 18:44:17 UTC
mate-themes-1.6.3-0.2.git52ee204.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-themes-1.6.3-0.2.git52ee204.fc19

Comment 4 Wolfgang Ulbrich 2013-12-08 18:47:21 UTC
Note, this update fix the greyout cursor theme slider with mate cursor theme.
You should also read this report and workaround.
https://bugzilla.redhat.com/show_bug.cgi?id=989152

Comment 5 Fedora Update System 2013-12-10 06:07:41 UTC
Package mate-themes-1.6.3-0.2.git52ee204.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-themes-1.6.3-0.2.git52ee204.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23081/mate-themes-1.6.3-0.2.git52ee204.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2013-12-19 07:19:56 UTC
mate-themes-1.6.3-0.2.git52ee204.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-12-19 07:20:03 UTC
mate-themes-1.6.3-0.2.git52ee204.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 jonathan baron 2013-12-19 20:36:53 UTC
This is now fixed. The cursor can be controlled through Customize, as describe above. This never worked reliably in Gnome either. So it is good.


Note You need to log in before you can comment on or make changes to this bug.