Bug 103942 - Errors building kernel on Hp zx6000 Itanium2
Errors building kernel on Hp zx6000 Itanium2
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-09-07 22:33 EDT by jahshaka
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-09-10 04:14:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jahshaka 2003-09-07 22:33:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ia64; en-US; rv:1.4) Gecko/20030902

Description of problem:
I have trouble building the kernel on my Hp zx6000. My system is totally up2date
and is running all the latest rpms as of Sept 7. 

The only chanes made to the default config were to set the processor to itanium2
and to enable Hp ZX chipset support. I also changed the radeon drivers to load
as a module vs as part of the kernel which was the default.

1. First problem i have is in xconfig but it seems minor:

xconfig gives the following errors in the terminal after configuration and
pressing the 'save and exit' button

ERROR - Attempting to write value for unconfigured variable (CONFIG_BLK_DEV_LOOP).
ERROR - Attempting to write value for unconfigured variable (CONFIG_BLK_DEV_NBD).
ERROR - Attempting to write value for unconfigured variable (CONFIG_BLK_DEV_RAM).

2. make dep works

3. make stops with the following errors every time

/usr/src/linux-2.4.21-1.1931.2.423.ent/include/asm/hw_irq.h: In function
/usr/src/linux-2.4.21-1.1931.2.423.ent/include/asm/hw_irq.h:102: warning: return
from incompatible pointer type
make[4]: *** [aic7xxx_osm.o] Error 1

if i disable the aix7xxx drivers (i also have to disable the e1000 drivers) it
then crashes trying to link the kernel

arch/ia64/kernel/head.o(.text+0x1e2): In function `_start':
: undefined reference to `early_printk'
mm/mm.o(.text+0x2c02): In function `follow_page':
: undefined reference to `pfn_valid'
mm/mm.o(.text+0x4fb62): In function `install_page':
: undefined reference to `pfn_valid'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.21-1.1931.2.423.ent'
make: *** [vmlinux] Error 2

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-1.1931.2.423.ent  gcc-3.2.3-18 

How reproducible:

Steps to Reproduce:
1. run make xconfiugre
2. make dep
3. make

Additional info:
Comment 1 jahshaka 2003-09-08 02:48:03 EDT
Tried to rebuild kernel from srpm using rpmbuild and its looking a lot better 
since it seems to apply all the patches, although it takes forever since 
apparently everything is turned on.

And it works! Very cool...

However it didnt work when i installed the srpm from up2date and built it that 
Comment 2 Arjan van de Ven 2003-09-08 03:21:54 EDT
Just "make" is not a valid make target...
"make compressed" is (for ia64)

Also, you have to start out with make mrproper, and then use one of our configs
as starting point.

Comment 3 jahshaka 2003-09-10 04:10:12 EDT
how do i get one of your configs? the only way i could figure this out was to
kill the srpm make process 1/2 way through and then get the .config out of the
BUILD directory...

your config worked though... only problem now is that if i open your config file
in xconfig (ie make xconfig and then load it in) it gets all corrupted when i
save it back out. I have to manually edit the .config file...

i guess you can close this out now...
Comment 4 Arjan van de Ven 2003-09-10 04:14:26 EDT
we ship the files in /boot
also they are in /usr/src/linux-2.4/configs

Note You need to log in before you can comment on or make changes to this bug.