Bug 103974 - Anaconda Bails Out After Install Image Transfer to Disk
Anaconda Bails Out After Install Image Transfer to Disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-08 14:05 EDT by Eugenia Loli-Queru
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: 0.94
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-30 00:36:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2003-09-08 14:05:08 EDT
Description of problem:
I tried both graphical and text mode installation on my AthlonXP computer, and
BOTH fail.
All goes ok in the first screens, then it is going to the install-packages
screen: there, it formats the partitions (a 12.5 GB / (hda2) and the swap (512
MB hda1)), then it says that it transfers the Install Image to the hard drive
(that completes ok too), and then for a second or two there is this "Transfer
PNP blah-blah" popup window (or something like "PN-something", can't read it
because it goes away fast) and then Anaconda dies and throws me out of X11.
In the text version of the installation the only error message I get is "Install
Exited Abnormally" and then it unmounts stuff and tells me to reboot.

Version-Release number of selected component (if applicable):
Severn beta1

How reproducible:
Always

Steps to Reproduce:
1. Install Severn on this PC
2.
3.
    

Actual Results:  Anaconda bails out

Expected Results:  Should install the packages

Additional info:

Please note that the hda2 that I try to install Severn, had Red Hat Linux 9 on
it, and format goes ok. On this same partition/computer I have installed many
older Red Hat Linuxes, this is the first time I get such an error on this
particular PC.

AthlonXP 1600+, 768 MB RAM, 40 GB Samsung IDE, 52x CDROM LG Goldstar IDE, 24x
CD-RW BTC IDE, Texas Instruments Firewire PCI card (RHL loads the ohci driver ok
in the begining of the installation), Yamaha Digital-XG PCI sound card
(supported too), GeForce 2MX, RealTek 8139c onboard NIC, onboard VIA AC97 sound
card, onboard Via Savage 2000 AGP card (disabled due to GeForce). This machine
never had a problem with Linux or Red Hat Linux in particular, before Severn.
Comment 1 Michael Fulbright 2003-09-10 14:57:46 EDT
Is this a CD based install?

Try 'acpi=off' also when you boot the installer ('linux acpi=off')

Comment 2 Eugenia Loli-Queru 2003-09-10 15:30:41 EDT
>Is this a CD based install?

Yes.
Please note the CD is not damanged, I have managed to install from the same CDs
on another PC with no problems.

>Try 'acpi=off' also when you boot the installer ('linux acpi=off')

Didn't help, it dies at the same place still.
Comment 3 Eugenia Loli-Queru 2003-09-10 15:48:46 EDT
Yup, just retried, this time booting from the other CD-rom. Installation is
repeatedly fails just after the Install Image is transfered to the / ext3 partition.

Is there a log somewhere where I can find?
Comment 4 Michael Fulbright 2003-09-15 17:56:20 EDT
If you look on VC3 and VC4 there is alot of info.

Also goto VC2 and look at /tmp/anaconda.log and /tmp/syslog.

Comment 5 Eugenia Loli-Queru 2003-09-15 19:06:43 EDT
I just checked it out and there is nothing unusual there. But I think I have
another clue for you (I would need RHL10 working as I need to write a review for
the online magazine I work for)...

So, this time I told anaconda to not format the partition (it is already
formatted from my previous attempts) and the installation went through to
actually install RPM packages. It successfully installed the install image to
the disk, did the "RPM transaction" thingie, then started to instrall RPM packages.

And after about 1-2 minutes, I got an error saying that the ncurses packages was
corrupted etc and Anaconda died (please note that there is nothing wrong with
the package or CD or even the CD-rom, I checked all that).

I believe that the crash of anaconda is time based !! It *only* happens when I
enter the screen where installs the RPMs (with the progress bars) and it happens
exactly on the same time after you entered that screen. If I do changes to the
installation (like this time I told it to not format my / which is a procedure
that takes place in that same screen), it takes less time to enter the actual
RPM installation phase, so it dies a bit afterwards! Erm, do I make some sense here?

After anaconda dies, the app says that lost connection to the X server and that
mini-wm had an I/O error or something (but I believe that error is not
anaconda's, it is just the result of anaconda's previous crash on itself).
Comment 6 Michael Fulbright 2003-09-17 12:14:26 EDT
I would still be suspicious of the CDs, I've seen CDs that are marginal work
sometimes and then other times cause erratic behavior.  The mediacheck won't
always catch CDs that are marginal.

You can try adding 'nofirewire' to the boot command line with 'acpi=off' so we
can remove that module as a possible problem source.

It really sounds like a kernel issue if what you are saying is that after a
certain period of uptime the system because unstable.   If you leave the machine
sitting for 20 minutes at the graphical 'welcome' screen, then proceed does it
die   when you would expect?
Comment 7 Eugenia Loli-Queru 2003-09-17 15:20:19 EDT
>I would still be suspicious of the CDs, 
>I've seen CDs that are marginal work 
>sometimes and then other times cause erratic behavior.
>  The mediacheck won't always catch CDs that are marginal.

I re-downloaded today the first ISO (from a different server: stanford.edu),
re-burned it, and re-checked it. Plus, I tried it with two different CD-ROMs.
Same exact problem happens again, at the exact same screen: "install exited
abnormally".

>You can try adding 'nofirewire' to the boot command 
>line with 'acpi=off' so we
>can remove that module as a possible problem source.

No effect.

>It really sounds like a kernel issue if what you 
>are saying is that after a
>certain period of uptime the system because unstable.
> If you leave the machine
sitting for 20 minutes at the graphical
> 'welcome' screen, then proceed does it die   when you would expect?

Just spent the last 2 hours leaving the machine untouched on several screens: no
problem happens on these. The machine dies only after it enters the "Install
Packages" screen, on either text or graphical installs. Logs don't reveal
anything weird going on.

Any other ideas? :(
Comment 8 Eugenia Loli-Queru 2003-09-17 16:01:21 EDT
Ok, I just re-burned the first CD, this time from inside Win2k3 (previous
writting attempts were with MacOSX and BeOS). Same problem happens, still. So,
it is not the CDs, or the way I am burning them (I am not a newbie on that anyway).

This time I told it again to not format the / partition so I could buy some time
in the "Install Packages" screen, and I was able to read the
/mnt/sysimage/root/install.log before Anaconda crash and RHL tell me to power
down the machine. So, the install.log tells me that the glibc RPM package (which
is the first RPM package installed) has an MD5 checksum error!
Now, I reboot, this time I tell it to not format the swap partition either so I
can buy a bit more time. This time it says that the ncurses package has an md5
error.
If I let the installation normally to go ahead, and tell it to format the
partitions, Anaconda dies in the "Starting RPM Transaction" window.

I do NOT believe this is a real MD5 checksum issue here. I tried different
CDroms, different CDs, different OS/programs to burn the CDs, even different
downloads of the same ISO. I believe that the problem is something else that is
happening on that specific PC (other PCs work with these installation CDs), and
while previous RHL versions were working fine on that same PC, it is only Severn
that misbehaving. BeOS and Win2k3 are also installed on that PC with no
problems. Any ideas what else it might be?
Comment 9 Michael Fulbright 2003-09-23 16:35:44 EDT
Well you could get into the installer and then use rpm to test the packages.
Just get to the first screen in the graphical part of the the install, hit
'cntl-alt-f2' and you'll see a command line prompt.

Then enter:

rpm -K --nogpg /mnt/source/RedHat/RPMS/*rpm

and see if any fail.
Comment 10 Eugenia Loli-Queru 2003-09-30 00:36:40 EDT
Works in the new fedora beta. Please close the bug.

Note You need to log in before you can comment on or make changes to this bug.