Bug 10398 - root and freshen options don't work together
root and freshen options don't work together
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-28 14:27 EST by advax
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-28 15:14:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description advax 2000-03-28 14:27:25 EST
The -F freshen option works OK if the --root option is not
given, but with --root does not seem to find the packages.

RPM version 3.0.3 i386

# rpm --root /hdb1 -q pam-0.68-7
pam-0.68-7
# ls -l ../../../updates/pam-0.68-10.i386.rpm
-rw-r--r--   1 278      278        627243 Jan  4 14:25
../../../updates/pam-0.68-10.i386.rpm

# rpm --root /hdb1 -Fv ../../../updates/pam-0.68-10.i386.rpm
rpm: no packages given for install

# rpm --root /hdb1 -Uh ../../../updates/glib-devel-1.2.6-2.i386.rpm
##################################################
Comment 1 Bill Nottingham 2000-03-28 15:14:59 EST
That's because it's checking packages against the non --root
filesystem.

You can't yet mix -F and --root.
Comment 2 Jeff Johnson 2000-06-23 10:56:23 EDT
This should be fixed in rpm-3.0.5 and rpm-4.0, available from
	ftp://ftp.rpm.org/pub/rpm/test
at the moment.

Note You need to log in before you can comment on or make changes to this bug.