Bug 103980 - Promise SATA 150 TX2plus/TX4 lacks support in kernel
Promise SATA 150 TX2plus/TX4 lacks support in kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-09-08 15:06 EDT by Peter Bieringer
Modified: 2011-05-15 11:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-29 15:32:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
2.4.22-bk53-libata1 for FC1 (229.73 KB, patch)
2003-11-28 18:31 EST, Pekka Pietikäinen
no flags Details | Diff

  None (edit)
Description Peter Bieringer 2003-09-08 15:06:23 EDT
Description of problem:
If possible, pls. add support of Promise SATA 150 TX2plus/TX4 to next kernel
releases, this would be great.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Promise SATA 150 TX4 card

Actual Results:  Not supported

Expected Results:  Supported

Additional info:

Sources for driver given by Promise:


works fine here compiled and insmod'ed on 2.4.20-20.7
Comment 1 Peter Bieringer 2003-09-09 16:37:50 EDT
Here some more information, looks like it's not so easy...


Newer Promise driver
Comment 2 Pekka Pietikäinen 2003-11-28 18:28:36 EST
Since I've heard no complaints about the libata patch and rpms
at http://www.ee.oulu.fi/~pp/fc1-libata I announced on fedora-devel a
while back, I might as use this bug as my RFE.

Patch attached, I have only heard VIA and Promise comments so far.
It's basically 2.4.22-bk53-libata1 merged to the fc1 kernel (+ a
0x3378 ID for promise I still haven't found out exists in the wild, or
works with the patch. Supposedly some ASUS boards do, but I haven't
been able to reliably verify this.)

Oops, looks like he's done minor tweaks since in
2.4.23-rc3-libata1.patch. If necessary (and a kernel with the patch
will eventually end up somewhere like a updates-testing kernel) I can
merge/test those changes and do a new patch. 
Comment 3 Pekka Pietikäinen 2003-11-28 18:31:07 EST
Created attachment 96245 [details]
2.4.22-bk53-libata1 for FC1
Comment 4 Peter Bieringer 2004-01-04 05:08:54 EST
Currently I use a vanilla 2.4.23 with the latest libata patch from:
And also tried the 2.4.22-1.2135.nptl on RHL 7.3

SATA is working (that's the good news), but the bad news is that
mkinitrd has problems in supporting "libata" as module. Reason: for
SATA support, 3 modules are required in following order: scsi_mod ->
libata -> sata_promise

mkinitrd has 2 options for additional module loading:
for the "libata" module, "--preload" is too early (libata requires
scsi_mod to be loaded), post loading after the scsi modules with
"--with" it's too late, because the "sata_promise" module was already
tried to load (but failed because of the missing "libata" module).

Looks like mkinitrd has to be extended for "libata" support, similar
to the already included "sd_mod" and "scsi_mod" support.

Workarounds and a fix for mkinitrd are posted here:
Comment 5 Michael 2004-01-30 05:05:55 EST
I also need support for the Promise SATA150 TX4. 

If there are issues or delays in incorporating this driver into the kernel ...

As a stopgap measure, it would be very useful to have this driver shipped as part of 
the "standard" external drivers that are offered as part of the installation. 

Should I file a bug report/feature request with Anaconda/Installation ?
Comment 6 David Lawrence 2004-09-29 15:32:57 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/
Comment 7 William M. Quarles 2011-05-15 11:07:45 EDT
This is still a bug as of Fedora 14. I was able to install Fedora 14 with my Promise Ultra ATA133 TX2 and my Promise SATA150 TX2plus, however I cannot boot from the Promise SATA150 TX2plus at all. It was the same computer both times, with the only difference being the hard drive controller card. It locks up at udev. After running yum via the rescue mode from the installation disc, I was able to get some kind of error code out of udev, but it still locks up. I'm guessing that this is still a problem seven years later? Please consider reopening this bug.

Note You need to log in before you can comment on or make changes to this bug.