Bug 104026 - Anaconda Does Not Support Compaq Presario 2170US Laptop Keyboard
Anaconda Does Not Support Compaq Presario 2170US Laptop Keyboard
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-09-08 23:47 EDT by Gabriel Donnell
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-09-18 18:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gabriel Donnell 2003-09-08 23:47:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:

I bought a Compaq Presario 2170US laptop because it had a very low cost.  I took
my chances with it being supported by Linux.

Unfortunately, I could not install Red Hat Linux 9.0 on it because anaconda does
not repond to the keyboard.  The boot prompt responds to the keyboard entries. 
However, after the system boots and anaconda starts, it does not respond to any
keyboard entries.

I figured the problem may be resolved in Red Hat Linux 9.0.93 (Severn) beta
version.  However, I had the same problem with it.

I tried SuSE 8.2, Knoppix 3.2 2003/07/26 and Gnoppix 0.4.2 2003/06/13 on the
laptop.  All of them booted and worked fine with the keyboard.  Therefore, the
problem is specific to Red Hat Linux.

I know my laptop may be too new for Red Hat Linux.  I could use another
distribution, but I prefer Red Hat Linux.  All my systems at home and work use
Red Hat Linux.

If there is a way for my to load Linux without anaconda, then please let me
know.  I have considered installing Red Hat Linux on the Compaq hard with my
job's Dell Latitude laptop.  Please provide any asistance.

Worse case scenario, I will use another Linux distribution until Red Hat Linux
works on my Compaq Presario 2170US laptop.

Gabriel Donnell

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Insert Red Hat Linux Shrike or Severn installation CD-ROM.
2. Turn on the system.
3. At boot prompt, wait, press enter, or enter linux.
4. At the media scan screen, notice that the keyboard does not work.

Actual Results:  No response from keyboard entries.

Expected Results:  Reponse from keyboard entries.

Additional info:
Comment 1 Michael Fulbright 2003-09-09 16:52:11 EDT
If it has an option in the BIOS regarding 'Legacy USB Emulation' or something to
that effect, trying turning it off.

You might want to try booting with 'nousb' as well.

We have not had any reports regarding this laptop so I'm curious what the issue is.
Comment 2 Gabriel Donnell 2003-09-09 17:52:29 EDT
Hello Michael Fulbright,

That resolved the problem.  Thanks a lot.

Below are the steps I followed:
1.  Turned on the laptop.
2.  Pressed F2 to go into the PhoenixBIOS Setup Utility.
3.  Pressed the right arrow button to select the "System Devices" menu.
4.  Pressed the down arrow button to select the "Legacy USB Support" item.
5.  Pressed the F5 or F6 button to change the value to "Disabled".
6.  Pressed the F10 button to save & exit the configurations.
7.  Inserted the first Red Hat Linux 9.0 installation CD-ROM. 
8.  Let the system booted.
9.  Pressed enter at the "boot:" prompt.  I DID NOT use "nousb".
10. Anaconda responded to my keyboard entries.
Comment 3 Gabriel Donnell 2003-09-09 18:27:32 EDT
Hello Michael Fulbright,

I really want to thank you for your assitance.  I wasted about a week messing
around with other Linux distributions.  I should have submitted this Bugzilla
report last week.

Downloading SuSE took about 2 days from the Georgia Institute of Technology
mirror which is the same one I use for downloading Red Hat Linux ISO images.
The SuSE downloads are not available in ISO formats like Red Hat Linux.
Plus, their network installation is not as easy or freely well documented
like Red Hat Linux.

I have Red Hat Linux system environments at home, work and client sites.  I
have invested a lot of time and effort implementing the system environments
with Red Hat Linux.  I configured the system environments to use the Red Hat
Linux kickstart installation method with the ISO images over the network with
Red Hat Linux DHCP, DNS & NFS servers.  It works like a charm.

I considered returning the laptop because I thought it did not support
Red Hat Linux.  Now, I can take advantage of the kickstart configuration
for my Compaq Presario 2170US laptop.

I am going to Best Buy or Compaq to request my refund for the Macro$hit Lose
XP license that they bundled with the laptop.  I have no need to use that
virus they call an operating system.  With the sale, rebates and refund for
the OS, the price of laptop should be around $600 US to $650 US.  That is
good considering that some several years old used laptops are going for
around $500 and up.

I know you guys are offered gifts all the time, and may not be allowed to
accept gifts.  However, if you are ever in the Atlanta Metro area, then
look me up.  I owe you a good dinner because you truelly saved me a lot
of time and money.  Otherwise, let me know if Red Hat has a way for pleased
people like to provide donations.  I already purchased for Red Hat Linux
several times.

Gabriel Donnell
A Satisfied Red Hat Linux System Administrator
Comment 4 Gabriel Donnell 2003-09-09 18:29:47 EDT
Hello Michael Fulbright,

This ticket can be closed.  I was not sure which item to select.

Gabriel Donnell

Note You need to log in before you can comment on or make changes to this bug.