Bug 104032 - floppy needs to be manually modprobed /insmodded
Summary: floppy needs to be manually modprobed /insmodded
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: modutils   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 08:19 UTC by Hans de Goede
Modified: 2014-03-17 02:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 20:13:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2003-09-09 08:19:07 UTC
Description of problem:
When using the floppy for example:
dd if=drvblock.img of=/dev/fd0
The floppy driver needs to be manually modprobed /insmodded

Version-Release number of selected component (if applicable):
modutils-2.4.25-8

I tried adding
alias block-major-2 floppy
to /etc/modules.conf, but that didn't help.

I also noticed that there now is a /etc/modprobe.conf which includes
/etc/modprobe.conf.dist, which does include "alias block-major-2 floppy"
I don't know which of these 2 files the current modprobe uses, but for some
reason I still needed to modprobe the floppy manually.

Comment 1 Bill Nottingham 2003-09-09 16:00:10 UTC
What kernel is this with?

Comment 2 Hans de Goede 2003-09-10 06:40:02 UTC
The default severn kernel

Comment 3 Bill Nottingham 2003-09-10 17:05:51 UTC
What does 'modprobe -c | grep block-major-2' say?

Comment 4 Hans de Goede 2003-09-11 06:21:44 UTC
Erm,

I neede my severn machine for production use, so I downgraded to a pristine RH9
install.

I take it you can't reproduce this?



Comment 5 Bill Nottingham 2003-09-11 20:01:20 UTC
Correct, I have a severn beta machine here and it works OK.

Comment 6 Hans de Goede 2003-09-11 20:10:12 UTC
Erm,

Maybe we should just close this bug and reopen it if anyone else gets bitten,
since its seems only my machine is affected and I can't reproduce it now.


Comment 7 Bill Nottingham 2003-09-11 20:13:21 UTC
OK.

Comment 8 Hans de Goede 2003-09-27 07:32:02 UTC
Hi,

This bug is gone on the same machine with Severn test2. So it can stay closed!



Note You need to log in before you can comment on or make changes to this bug.