Bug 104034 - glade2 dumps core on xscreensaver-demo.glade2
glade2 dumps core on xscreensaver-demo.glade2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: glade2 (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-09 05:14 EDT by Jamie Zawinski
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-07 16:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Zawinski 2003-09-09 05:14:44 EDT
glade-2 works in general, but the xscreensaver .glade2 file makes it segv.

glade2-1.1.3-3
Red Hat 9
Linux 2.4.20-8smp #1 SMP Thu Mar 13 16:43:01 EST 2003 i686 athlon i386 GNU/Linux

    % gdb `which glade-2`
    ...
    (gdb) r xscreensaver-demo.glade2
    Starting program: /usr/bin/glade-2 xscreensaver-demo.glade2
    [New Thread 1086021728 (LWP 31597)]
    Breakpoint 1 at 0x42029cd6
    GTK Accessibility Module initialized

    Program received signal SIGSEGV, Segmentation fault.
    [Switching to Thread 1086021728 (LWP 31597)]
    0x00000000 in ?? ()
    (gdb) bt
    #0  0x00000000 in ?? ()
    (gdb) 

This is with xscreensaver/driver/xscreensaver-demo.glade2 from any of
xscreensaver 4.11, 4.12, or 4.13 (the last time this file changed was
in 4.11, when the xpm references were trivially changed to pngs; there
hasn't been a substantial change to it since xscreensaver 4.06.)
Comment 1 Michael Lee Yohe 2003-09-09 15:50:33 EDT
Have you tried Glade 2 out of Rawhide?  The version included with Red Hat Linux
9 is outdated.  Rawhide contains the final version of Glade 2 (2.0.0-1) that may
have something that already fixes your problem.
Comment 2 Owen Taylor 2003-10-07 16:35:45 EDT
Seems to work fine with glade2-2.0.0.

Note You need to log in before you can comment on or make changes to this bug.