Bug 1040364 - postgresql should trust to connections during upgrade process
Summary: postgresql should trust to connections during upgrade process
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Raiskup
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1043477
TreeView+ depends on / blocked
 
Reported: 2013-12-11 10:10 UTC by Jozef Mlich
Modified: 2013-12-21 02:29 UTC (History)
6 users (show)

Fixed In Version: postgresql-9.3.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1043477 (view as bug list)
Environment:
Last Closed: 2013-12-21 02:29:25 UTC


Attachments (Terms of Use)
proposed patch (748 bytes, patch)
2013-12-11 10:10 UTC, Jozef Mlich
no flags Details | Diff

Description Jozef Mlich 2013-12-11 10:10:40 UTC
Created attachment 835206 [details]
proposed patch

Description of problem:
The update may fail if pg_hba.conf contains specific settings. It seems reasonable to assume that the user has changed the default settings.


Version-Release number of selected component (if applicable):
The postgresql-setup is fedora/rhel specific script. It is included in all currently supported versions of fedora (rawhide-f18).

How reproducible:

Steps to Reproduce:
$ echo "host    all         all         0.0.0.0          0.0.0.0      md5
host    all         all         ::1/128                       md5
local   all         all                                       md5">/var/lib/pgsql/data/pg_hba.conf
$ postgresql-setup upgrade

Actual results:
upgrade failed


Expected results:
Sucessfull upgrade. Additionally, the user should be warned about configuration changes.

Additional info:
See attached patch.

Comment 1 Pavel Raiskup 2013-12-16 13:52:45 UTC
Fedora commit, thanks Jozef!
https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20131216/1159834.html

It seems to be useful for f20 also ~> backpatched.

Comment 2 Fedora Update System 2013-12-16 15:33:03 UTC
postgresql-9.3.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/postgresql-9.3.2-2.fc20

Comment 3 Fedora Update System 2013-12-17 19:08:40 UTC
Package postgresql-9.3.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing postgresql-9.3.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23489/postgresql-9.3.2-2.fc20
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2013-12-21 02:29:25 UTC
postgresql-9.3.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.