Bug 10409 - agp driver not build
agp driver not build
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-29 06:45 EST by dbarth
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-12 11:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dbarth 2000-03-29 06:45:02 EST
Even if the RPM tries to build the AGP module (and actually includes
agpgart.h in the exported files), the module is not build.

Playing the spec file "by hand" :

cp i386/boot/defconfig (here AGP _is_ enabled)
make oldconfig
-> here .config says AGP _is_NOT_ enabled

Hope this helps
Comment 1 Antti Andreimann 2000-03-31 07:51:59 EST
The problem is in file drivers/char/Config.in where AGP is defined as
dep_tristate that must be no.
I'll attach 2 files here that will fix that problem. 1 of them is a patch
against the agp patch ;-) and another one is a patch against the kernel tree.
I hope you can inform authors of the AGP patch about this problem too since Im
again too lazy to do it myself.
Comment 2 Antti Andreimann 2000-03-31 08:02:59 EST
Bleh! It seems that only bug owner can attach files.
So I'll have to paste the patches here.

First one (against AGP patch)
============================= CUT HERE ====================================
--- /usr/src/redhat/SOURCES/linux-2.2.14-newagpdist.patch.old	Fri Mar 31
14:53:47 2000
+++ /usr/src/redhat/SOURCES/linux-2.2.14-newagpdist.patch	Fri Mar 31 14:53:17
2000
@@ -3818,7 +3818,7 @@
  fi

 +if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
-+   dep_tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP n
++   tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP
 +   if [ "$CONFIG_AGP" = "m" ]; then
 +      bool '   Intel 440LX/BX/GX support' CONFIG_AGP_INTEL
 +      bool '   Intel I810/I810 DC100/I810e support' CONFIG_AGP_I810
===================== END of Patch1 ====================================
Second one (against kernel source tree)
========================= CUT HERE =====================================
--- linux/drivers/char/Config.in.agpfix	Fri Mar 31 14:50:29 2000
+++ linux/drivers/char/Config.in	Fri Mar 31 14:45:22 2000
@@ -117,7 +117,7 @@ if [ "$CONFIG_ALPHA_BOOK1" = "y" ]; then
 fi

 if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
-   dep_tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP n
+   tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP
    if [ "$CONFIG_AGP" != "n" ]; then
       bool '   Intel 440LX/BX/GX support' CONFIG_AGP_INTEL
       bool '   Intel I810/I810 DC100/I810e support' CONFIG_AGP_I810
========================== END of Patch2 =================================
Comment 3 Antti Andreimann 2000-03-31 10:00:59 EST
Grr! Looks like I made the post a bit too early.
I should of tested the patch first :-(
There are actually 2 agp patches and the fix is the one that needs to be
fixed (ironic isn't it). And I can't figure out if AGP is supposed to remain
module or can it be compiled into kernel too. Configure.help says that you
should say Y or M here, but the original agp patch has dep_tristate specifying
that it can't be compiled into kernel. Go figure ;-) I guess it would be wise to
test if it can be compiled into kernel. Anyways here is another patch that's
against the correct patch. If AGP can't be compiled into kernel the tristate
should be set to dep_tristate again, but the last argument must be "m" not "n".
=============================== CUT HERE =====================================
--- linux-2.2.14-agphjlfixes.patch.orig	Fri Mar 31 16:55:59 2000
+++ linux-2.2.14-agphjlfixes.patch	Fri Mar 31 16:56:09 2000
@@ -343,7 +343,7 @@
  if [ "$CONFIG_EXPERIMENTAL" = "y" ]; then
 -   dep_tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP m
 -   if [ "$CONFIG_AGP" = "m" ]; then
-+   dep_tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP n
++   tristate '/dev/agpgart (AGP Support) (EXPERIMENTAL)' CONFIG_AGP
 +   if [ "$CONFIG_AGP" != "n" ]; then
        bool '   Intel 440LX/BX/GX support' CONFIG_AGP_INTEL
        bool '   Intel I810/I810 DC100/I810e support' CONFIG_AGP_I810
=============================== END of Patch ===============================
Comment 4 dbarth 2000-04-12 11:35:59 EDT
the quick fix to this problem is to just edit by hand the patch file called
linux-2.2.14-agphjlfixes.patch
at line 346 replace the 'n' at the end of the line with 'm' to build the driver
as a module

rebuilding the kernel packages with this quick fix ensures the driver is build
correctly

bump up the release number accordingly

hope this helps
Comment 5 Michael K. Johnson 2000-07-31 17:00:22 EDT
The current RawHide/Beta kernels build in agp support.

Note You need to log in before you can comment on or make changes to this bug.