Bug 104127 - dubious Obsoletes forces "update" to older package
dubious Obsoletes forces "update" to older package
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 05:25 EDT by Ronan Waide
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-29 17:07:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ronan Waide 2003-09-10 05:25:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
The "Obsoletes" field in xscreensaver specifies that it obsoletes
xscreensaver-gl regardless of version, presumably since the GL screensavers are
now included with the xscreensaver package. The upstream source, however, still
splits the GL screensavers out separately. The net result of this is that if the
upstream version is installed from its default RPMS:

Waider (qaz) $ > rpm -qa xscreensaver\*
xscreensaver-4.12-1
xscreensaver-gl-4.12-1

up2date wants to downgrade back to 4.07-2 because of the "obsolete"
xscreensaver-gl package:

Waider (qaz) $ > up2date --list

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
xscreensaver                            4.07           2                   

The following Packages are obsoleted by newer packages:

Name-Version-Release        obsoleted by      Name-Version-Release
-------------------------------------------------------------------------------
xscreensaver-gl-4.12-1                  xscreensaver-4.07-2                     


Version-Release number of selected component (if applicable):
4.07-2

How reproducible:
Always

Steps to Reproduce:
1. Build xscreensaver 4.12 or better from upstream source
2. Run up2date --list

Actual Results:  up2date insists that an older version of xscreensaver needs to
be installed (NB, it is not able to install it /because/ it's an older version)

Expected Results:  up2date should list the system as fully up-to-date

Additional info:
This may be a bug in up2date rather than xscreensaver's packaging. I have not
checked to see if changing the Obsoletes tag to "xscreensaver-gl < 4.07-2" or
similar fixes the problem (nor do I know if this is possible)
Comment 1 Warren Togami 2004-08-29 17:07:17 EDT
I did some digging, and the official xscreensaver homepage does not
have any RPMS of their own.  This is not a serious problem.

Note You need to log in before you can comment on or make changes to this bug.