Bug 104144 - i810 DRM kernel module ignored, only user-level XFree86 i810 driver used
i810 DRM kernel module ignored, only user-level XFree86 i810 driver used
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 10:24 EDT by William M. Quarles
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-25 06:18:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The requested config file (3.19 KB, text/plain)
2003-10-02 11:38 EDT, William M. Quarles
no flags Details

  None (edit)
Description William M. Quarles 2003-09-10 10:24:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
After configuring for the i810, XFree86 does not use the DRM kernel driver, it
instead uses a user-level driver that does not offer acceleration.  Even if the
kernel module is loaded, XFree86 ignores it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use redhat-config-xfree86
2.
3.
    

Actual Results:  No acceleration.

Expected Results:  Use of accelerated DRM kernel driver.

Additional info:
Comment 1 Mike A. Harris 2003-09-11 03:17:24 EDT
You misunderstand how XFree86 works.  DRM modules are kernel modules.  The
X server does not every use a kernel module.  The X server loads X server
modules.  An X server using DRI, loads the X server module, and causes
the kernel to load the kernel DRM module.  In either case, the X server
"user" module is always used.

Intel video hardware does not support 3D acceleration in every single video
mode with every single color depth.  Please attach your config file, log
file and /var/log/messages file from a single invocation of the X server
as uncompressed individual files using bugzilla's file attachment feature
below and we can investigate wether it is operating correctly, or wether
you have just chosen a configuration incompatible with DRI.
Comment 2 William M. Quarles 2003-10-02 11:38:27 EDT
Created attachment 94880 [details]
The requested config file

I understand what you are saying.
I read the DRI User's Guide, which said that only 16 bit/pixel color depth is
currently supported.  Resolution is irrelevant (or my resolution is less than
their user's guide's configuration sample, so I think I would be fine anyways).
 So I manually changed the configuration to that.  I exited and restarted X,
then entered the redhat-config-xfree86 again.  The acceleration option was
still greyed out.  Sounds like at this point it still isn't working.

So I manually edited the configuration again, telling it to load DRI.  The
kernel module was loaded, and things seemed to be moving a little faster.  I
tried starting Chromium, and the display was accelerated, but completely
garbled, I like someone took apart a puzzle making up what was displayed in the
window, and just scatterred it all near the top of monitor.  Tux Racer gave
similar results.  I tried commenting out the frame buffer module from the
XF86Config file, but that did not fix the error.  So while the DRM modules is
now loaded and automatically used, it is not giving desired results.

Attached is a copy of my config file.
Comment 3 William M. Quarles 2003-10-03 22:26:55 EDT
I switched the video memory back to 4 MB (manually), DRI is still loaded, the
kernel module is still loaded, the mess is gone, no noticeable 3D acceleration.
 I would be guessing that the DRI documentation is incorrect in not specifying
that something more than 16-bit/pixel depth is necessary for DRI acceleration to
work.  Also it would be wrong for saying that the amount of memory used for
video can be modified simply by editing the config file.
Comment 4 Mike Chambers 2004-01-29 08:40:34 EST
ping...

Does this now work with information supplied and/or with upgraded
packages?
Comment 5 Mike A. Harris 2004-02-25 06:18:16 EST
I have confirmed that Intel i810 video, when properly configured
to 16 bit depth, with the Load "dri" module present in the config
file, as configured by running:

redhat-config-xfree86 --reconfig   and specifying 16 bit depth,
works properly in Red Hat Linux 9 on a properly updated system
which includes all updates released by Red Hat to date, using
the "i810" driver.

Additionally, I've had other people test this and it also works
properly for them as well.  Most likely the problem that you
are having is not a driver or XFree86 bug, but either a
configuration problem on your end, or a buggy BIOS which limits
memory, so that DRI will not work correctly.  If you require
technical assistance in order to try and resolve the configuration
or BIOS issue, you may wish to subscribe to the xfree86@xfree86.org
mailing list and seek assistance there.

Closing as 'WORKSFORME'

Note You need to log in before you can comment on or make changes to this bug.