Bug 104161 - gcc-3.3/gcc-3.3.1 internal error on alpha.
gcc-3.3/gcc-3.3.1 internal error on alpha.
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 12:49 EDT by Balint Cristian
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 00:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Balint Cristian 2003-09-10 12:49:49 EDT
Description of problem: 
 
While compile glibc on alpha/linux encounter an internal gcc error, 
in fact the problem is with -O3 if i change to -O2 evrything will be ok 
no more internal error and the code run fine. 
 
Version-Release number of selected component (if applicable): 
gcc-3.2.3-82 
 
How reproducible: 
Try compile with newer gcc-3.3.1 for ex. or gcc-3.3 
except: gcc-3.2.3-6 is OK or use -O2 instead -O3 is OK. 
 
 
 
Additional info: 
 
Little debug: 
make -s -C libio subdir_lib 
make[2]: Entering directory 
`/usr/src/redhat/BUILD/glibc-2.3.2-200309061641/libio' 
mkdir /usr/src/redhat/BUILD/glibc-2.3.2-200309061641/build-alpha-linux/libio 
fileops.c: In function `mmap_remap_check': 
fileops.c:614: error: unrecognizable insn: 
(insn 305 383 306 17 0x20002992580 (set (reg/f:DI 212) 
        (symbol_ref:DI ("@L_IO_file_jumps"))) -1 (nil) 
    (expr_list:REG_EQUAL (symbol_ref:DI ("@L_IO_file_jumps")) 
        (nil))) 
fileops.c:614: internal compiler error: in extract_insn, at recog.c:2175 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions. 
Preprocessed source stored into /tmp/ccqYcQI7.out file, please attach this to 
your bugreport 
make[2]: *** 
[/usr/src/redhat/BUILD/glibc-2.3.2-200309061641/build-alpha-linux/libio/fileops.o] 
Error 1 
make[2]: Leaving directory 
`/usr/src/redhat/BUILD/glibc-2.3.2-200309061641/libio' 
make[1]: *** [libio/subdir_lib] Error 2 
make[1]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.3.2-200309061641' 
make: *** [all] Error 2 
error: Bad exit status from /var/tmp/rpm-tmp.19289 (%build) 
 
 
And here the file /tmp/ccqYcQI7.out : 
 
www.rdsor.ro/ccqYcQI7.out 
 
If encounter problems downloading debug file contact me: 
rezso@rdsor.ro
Comment 1 Richard Henderson 2004-10-04 00:09:04 EDT
404 file not found.

Note You need to log in before you can comment on or make changes to this bug.