Bug 104170 - up2date fails to start after upgrading itself from RHN
Summary: up2date fails to start after upgrading itself from RHN
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-10 18:14 UTC by Michael K. Johnson
Modified: 2007-04-18 16:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-16 23:06:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael K. Johnson 2003-09-10 18:14:06 UTC
Description of problem:
I ran with up2date --nosig from a recent version of up2date
it told me there was a new version in the channel and offered to just update
that version of up2date, and I said yes
when it tried to restart up2date, I got the help message
$ up2date --nosig
New Up2date available
Restarting up2date
$ Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
                                                                                
No interactive mode available
Please specify either -l, -u, --nox, or package names as command line
arguments.usage: up2date [OPTIONS] [<packages>]
(blah blah blah)
...
yes, I am going through userhelper


Version-Release number of selected component (if applicable):
updating from up2date-3.9.24-1 -> up2date-3.9.25-2

How reproducible: reliably


Steps to Reproduce:
1. install up2date-3.9.24-1
2. run up2date --nosig as a normal user (--nosig may not be required)
3. accept updating to new version of up2date from RHN
4. profit!

Comment 1 Adrian Likins 2003-09-10 20:00:10 UTC
fixed in cvs, should land in 3.1.26 or so

Comment 2 Michael Young 2003-09-10 22:52:45 UTC
Presumably ^3.1.26^3.9.26^. Also this bug is a duplicate of Bug 103185.

Comment 3 Michael K. Johnson 2003-09-11 14:39:10 UTC
Happened again this morning up2dateing (again, with --nosig) to up2date-3.9.26-2

Comment 4 Chris Ricker 2003-09-11 17:49:04 UTC
<aol>Me too, though I didn't use --nosig</aol>

Comment 5 Adrian Likins 2003-09-11 21:03:39 UTC
up2dating to 3.9.26 will still break (bug is in <= 3.9.25).
Should go away updating 3.9.26 to anything newer. 


Comment 6 Chris Ricker 2003-09-16 23:06:31 UTC
This appears fixed -- worked for me going to up2date-3.9.28-2




Note You need to log in before you can comment on or make changes to this bug.