Bug 104179 - useradd does not allow dots in the username
useradd does not allow dots in the username
Status: CLOSED DUPLICATE of bug 89205
Product: Red Hat Linux
Classification: Retired
Component: shadow-utils (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-10 16:53 EDT by Rishi Gangoly
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for chkname.c (508 bytes, patch)
2003-09-10 16:57 EDT, Rishi Gangoly
no flags Details | Diff

  None (edit)
Description Rishi Gangoly 2003-09-10 16:53:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
useradd does not allow dots in the username. See the error it gives.

# useradd rishi.g
useradd: invalid user name 'rishi.g'



Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-6

How reproducible:
Always

Steps to Reproduce:
1. useradd abc.xyz
    

Actual Results:  useradd: invalid user name 'abc.xyz'

Expected Results:  it should have returned to the prompt without an error and created the user in the system.

Additional info:

I've posted this pub on a newsgroup. See the thread for responses to it.

http://www.google.com/groups?hl=en&lr=&ie=UTF-8&threadm=1e6d1789.0309050810.45e1cf51%40posting.google.com&rnum=1&prev=/groups%3Fsafe%3Dimages%26ie%3DISO-8859-1%26as_uauthors%3Drishi%40theargoncompany.com%26lr%3D%26hl%3Den

Another nice person gave me a patch for the file 'chkname.c' that is buggy.

I would be happy to sent the patch for this program.
Comment 1 Rishi Gangoly 2003-09-10 16:57:52 EDT
Created attachment 94389 [details]
Patch for chkname.c 

This is a patch that "Torsten Finke" created and sent to me via e-mail.

Notes from the author...
- there is absolutely no warranty; 

;-)
Comment 2 Jeff Nessen 2003-10-10 23:37:44 EDT
I am also experiencing this problem.  Have you tested against the beta of RHES
AS 3.0?  I have a customer who just went live and has 6,000 users on AS 2.1. 
Every username has a . in it.  If this problem exists in AS 3.0, that will
preclude any future upgrades, without customizing shadow_utils.
Comment 3 Milan Kerslager 2003-10-22 23:54:27 EDT
The patch #94389 does not work. See bug #89205 for better solution.

*** This bug has been marked as a duplicate of 89205 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.