Bug 10421 - autofs fails on NIS based auto.home (auto.master local file)
autofs fails on NIS based auto.home (auto.master local file)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-29 14:38 EST by peter
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-06 19:12:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter 2000-03-29 14:38:37 EST
autofs in 6.2 fails to work with an ordninary NIS based auto.home map.
It also fails with a local map served from NIS, auto.ic.

This works with 6.1. It also works if I downgradethe rpm for autofs
to the same version in 6.1 on a 6.2 install

The auto.master file is:

	/misc /etc/auto.misc
	/home  auto.home
	/ic     auto.ic

Auto.home map can be seen via ypcat on the 6.2 machine:

%ypcat auto.home
tucson:/export/home/pcollins
quoll:/export/home/michael
akira:/export/home/akira/&


but automount doesn't work:

[peterc@gila peterc]$ ls ~pcollins
ls: /home/pcollins: No such file or directory
Comment 1 chauvin 2000-04-01 04:15:59 EST
the autofs start script (incorrectly) never looks for nis maps if
/etc/auto.master exists.

see bug 5796 from redhat-6.1 (not fixed).

auotfs:
#
# Check for local maps to be loaded
#
if [ -f /etc/auto.master ]
then
    process auto.master
else
    check for NIS maps
fi

it's easy to fix:  unconditionally look for the NIS maps.
Comment 2 chauvin 2000-04-01 04:17:59 EST
the autofs start script (incorrectly) never looks for nis maps if
/etc/auto.master exists.

see bug 5796 from redhat-6.1 (not fixed).

auotfs:
#
# Check for local maps to be loaded
#
if [ -f /etc/auto.master ]
then
    process auto.master
else
    check for NIS maps
fi

it's easy to fix:  unconditionally look for the NIS maps.
Comment 3 peter 2000-04-03 13:06:59 EDT
See bug 10471 for a patch to this problem and a better description.
Bug 5796 is not exactly what is going on here, as auto.master is
a local file not an NIS map. But when processing the local auto.master
autofs forgets to consider that auto.master may refer to MIS maps
for auto.home, etc.
Comment 4 peter 2000-04-03 14:06:59 EDT
Looks like the map type is missing in this case. Here's the change I'm using:

[root@localhost init.d]# diff autofs autofs.redhat.org
99c99
< 		    echo "$DAEMON $mountoptions $dir yp `basename $map` $options
$localoptions"
---
> 		    echo "$DAEMON $mountoptions $dir `basename $map` $options $localoptions"
[root@localhost init.d]# diff -e autofs.redhat.org autofs
99c
		    echo "$DAEMON $mountoptions $dir yp `basename $map` $options
$localoptions"
Comment 5 Nalin Dahyabhai 2000-04-05 16:08:59 EDT
This *should* be cleared up in 3.1.4-6, which cleans up the init script a bit,
in the next Raw Hide (ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/).
Please let me know whether or not it solves the problems you're experiencing.
Comment 6 Anonymous 2000-04-06 18:56:59 EDT
I must second this problem.  I upgraded to 6.2 today and my autofs mounts of NIS
supplied maps immediately stopped working.  My /etc/auto.master entry was:

/users	auto_home

which, under 6.1, correctly fetched the auto_home (or, if you prefer, auto.home)
map from NIS and mounted it the appropriate directory.

However, after upgrading the 6.2, this feature stopped working and an error was
generated to /var/log/messages everytime an attempt was made to access an
automounted directory under /users.

The error complains about not being able to load one of autofs shared libraries:

Apr  6 14:11:54 gkar automount[572]: cannot open lookup module auto_home
(/usr/lib/autofs//lookup_auto_home.so: cannot open shared object file: No such
file or directory)

So, it looks like autofs is trying to incorrectly invoke the lookup_yp.so
library.

Clay
Comment 7 Nalin Dahyabhai 2000-04-06 19:12:59 EDT
Clay, please update to the Raw Hide version of the package (which, until Raw
Hide gets updated, can now be found in http://people.redhat.com/nalin/test/)
and let me know if it fixes the problem.
Comment 8 Nalin Dahyabhai 2000-06-10 17:24:06 EDT
I've heard numerous success reports about the fix, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.