Bug 10424 - scsi bus resets when using kernel compiled with egcs1.1.2-13
scsi bus resets when using kernel compiled with egcs1.1.2-13
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-29 17:52 EST by dan carter
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 17:17:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dan carter 2000-03-29 17:52:32 EST
This bug appears to be the same as reported in
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=4737
and
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=4608

Those bug reports have no detail of the resolution and after corresponding
with a user who reported one of them it appears the bugs have been marked
as resolved without any resolution being found.

The further insight that i can give to this problem is that it is not
kernel2.2.5-22 that causes the problems but rather egcs1.1.2-13 which i
presume kernel2.2.5-22 is compiled with.
I have tried the kernels from rawhide, i have tried the kernels from
6.2beta.  All exhibit the same problem.  If i have egcs1.1.2-13 installed
and compile my own kernel then i get the same problem, if i have
egcs1.1.2-12 installed and compile my own kernel then it does not give scsi
problems.

As in the other two reports the machine is a SPARCStation5.


[root@mowgli log]$ cat /proc/scsi/esp/0
Sparc ESP Host Adapter:
        PROM node               ffd3d1d8
        PROM name               esp
        ESP Model               FAS100A
        DMA Revision            Rev 2
        Live Targets            [ 1 3 4 6 ]

Target #        config3         Sync Capabilities       Disconnect
Wide
1               00000003        [2f,04]                 yes             no
3               00000003        [2f,04]                 yes             no
4               00000003        [2f,04]                 yes             no
6               00000001        [2f,04]                 yes             no
[root@mowgli log]$
[root@mowgli log]$ cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: CONNER   Model: CP30548  SUN0535 Rev: B0CD
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 03 Lun: 00
  Vendor: CONNER   Model: CP30548  SUN0535 Rev: B0CD
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: QUANTUM  Model: FIREBALL_TM3200S Rev: 300N
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: TOSHIBA  Model: XM-3401TASUNSLCD Rev: 3593
  Type:   CD-ROM                           ANSI SCSI revision: 02
[root@mowgli log]
[root@mowgli log]$ uname -a
Linux mowgli 2.2.14 #5 Wed Mar 22 18:13:22 NZST 2000 sparc unknown


Please don't close this bug without fixing it.  I'd like to get a more
recent copy of redhat, but there is no point if it will not work on this
machine.
Comment 1 dan carter 2000-04-06 19:57:59 EDT
I just downloaded and tried out the kernel from redhat6.2/sparc
 (kernel-2.2.14-5.0.sparc.rpm).  Identical results.
 It boots up.  Gets into init goes OK until it starts cron and then starts
 spitting out scsi errors:
 esp0: resetting scsi bus
 esp0: bus reset interrupt
 esp0: bus reset interrupt
 EXT2-fs error host 0 channel 0 id 4 lun=0 return code = 28000000
 Additional sense indicates logical unit not ready, cause not reportable.

 The things normally started by cron do not start, eg i get an email from cron :
 Subject: Cron <dcarter@mowgli> /home/dcarter/distributed.net/start-pproxy
 /home/dcarter/distributed.net/start-pproxy:
 /home/dcarter/distributed.net/proxyper-current/proxyper: Input/output
 error

 While it completes bootin this sequence of messages:
 esp0: resetting scsi bus
 esp0: bus reset interrupt
 esp0: bus reset interrupt
 continues being outputted to the console.

 Eventually it finished booting and logging in works, but doing anything like
 'ls' causes this error sequence to be printed out again, eventually ls
succeeds.

 I've rebooted back to an egcs-1.1.2-12 compiled kernel and all is well again.
Comment 2 dan carter 2000-05-16 23:01:59 EDT
OK, after months of work, here's what i did.

The compiler that ships with redhat6.0 doesn't cause scsi errors, but does
produce an unstable kernel (random lockups, uptimes rarely reaching 6 days).
Any more recent compilers cause the scsi errors.  I have the gcc 2.95 compiler
from mandrake 7.0/sparc installed at the moment, i got the same scsi errors
with that.

However, i have just tried the 2.3.99-pre8 kernel.  That does not have scsi
errors, so it appears there is a bug in the scsi driver that was only apparent
with recent compilers, and is not present in the 2.3 kernels.  You might like
to give 2.3 a try yourself.  I imagine it will work with the updated redhat
versions of gcc/egcs too.
Comment 3 dan carter 2000-10-01 19:00:39 EDT
Status: NEW?  This bug was reported 7 months ago!

Does anyone at redhat look at these bugs?  

If i find that this bug is being actively worked on then perhaps i can postpone
the switchback to solaris until we have tried the fix.
Comment 4 Alan Cox 2002-12-14 17:17:32 EST
This was fixed a long time back but the bug never got closed for some reason.
Probably because Sparc got dropped.

Just tidying up

Note You need to log in before you can comment on or make changes to this bug.