Bug 104244 - ValueError: min() or max() arg is an empty sequence
Summary: ValueError: min() or max() arg is an empty sequence
Status: CLOSED DUPLICATE of bug 104152
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date   
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-11 18:13 UTC by John Reiser
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Reiser 2003-09-11 18:13:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030902

Description of problem:
$ up2date &
# give superuser password, click Forward as often as necessary.

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1439, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence


Version-Release number of selected component (if applicable):
up2date-3.9.25-1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. GUI update taroon (beta 2) all packages to 2003-09-11 1730 UTC (10:30am PDT
Thursday)
2. reboot, selecting new kernel
3. run manual update in background "up2date &" from xterm console
4. give superuser password, click Forward, ...
    

Actual Results:  crashed with:
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1439, in onSkippedPagePrepare
    maxlength = max(map(lambda x: len(x[0][0]), self.skipPkgList)) * 8
ValueError: min() or max() arg is an empty sequence

Expected Results:  no crash

Additional info:

Trying "up2date &" two more times, both terminated normally (failed to crash)
with "Your system is fully updated" [or something like that].

Comment 1 Adrian Likins 2003-09-12 19:36:07 UTC

*** This bug has been marked as a duplicate of 104152 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:33 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.