Bug 104250 - LTC4333-
LTC4333-
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
3.0
All Linux
high Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 15:28 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-12 06:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-09-11 15:28:08 EDT
The following has be reported by IBM LTC:  
Hardware Environment: Any system.

Software Environment: Beta2 Red Hat ( uname -vrm
2.4.21-1.1931.2.399.ent #1 SMP Wed Aug 20 15:24:26 EDT 2003 ppc64)

Steps to Reproduce:
An error message "Input/ouput error" shows up when we copy a file from a NFS to 
local directory with -f option.

For example: Assume that <NFS DIR> is a NFS directory and <LOCAL DIR> is any 
local directory.

If we issue the command below 
    cp -p -f /<NFS DIR>/anyfile.txt  /<LOCAL DIR>/
we will get the below error message:
    cp: `/<NFS DIR>/anyfile.txt': Input/output error

Although the file is copied successfully, the return code is "1". This problem 
cause our XL Fortran builds to fail because the build scripts rely on the 
return code and since the return code is "1" in this case, the build scripts 
thinks that the build fails. The problem is not reproducible with Beta1 RH.

Would you please fix the problem so that we can start building XL Fortran on 
Beta2 RH.
Thanks.










1.
2.
3.

Actual Results:

Expected Results:

Additional Information:Chinh,
p-series development scream team will need the p-series machine model you are 
using.
Also, they will need to know the file system type you are using for your 
partitions.   Thanks.


Seems that the ACL fetch over NFS fails:

close(4)                                = 0
close(3)                                = 0
utime("/tmp/foobar", [2003/09/11-09:45:46, 2003/09/11-09:45:46]) = 0
chown("/tmp/foobar", 0, 0)              = 0
getxattr("foobar", "system.posix_acl_access", 0xffffe220, 132) = -1 EIO
(Input/output error)
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=2601, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40017000
read(3, "# Locale name alias data base.\n#"..., 4096) = 2601

Do we know if this fails on Intel too? I only have ppc64 machines here.My office
mate has an 8-way with Beta 2 installed.
The copy over NFS seems to work fine on i386
I used both root id and a normal user id


This could be problem with 64 bit stuff ?  I don't have IA64 machine to try 
this on.

Salina
-----------------------------------------------------------------------



[root@milicent root]# mount skyline:/install /mnt
mount: skyline:/install failed, reason given by server: Permission denied
[root@milicent root]# mount skyline:/install/SuSE/SLES/8 /mnt
[root@milicent root]# ls /mnt
CD1  rmsp2b1rpms  SP1  SP2  SP2A  SP3B2
[root@milicent root]# cd /mnt/CD1
[root@milicent CD1]# ls
ARCHIVES.gz  COPYING         INDEX.gz               media.2      SuSEgo.ico
autorun.inf  COPYING.tex     install_sles8_rpms.sh  media.3      TRANS.TBL
autorun.sh   COPYRIGHT       LICENSE.TXT            pubring.gpg  UnitedLinux
boot         COPYRIGHT.yast  LIZENZ.TXT             README       yast
ChangeLog    docu            ls-lR.gz               README.DOS
content      dosutils        media.1                suse
[root@milicent CD1]# cp README /tmp/README
[root@milicent CD1]# uname -a
Linux milicent.ltc.austin.ibm.com 2.4.21-1.1931.2.399.entsmp #1 SMP Wed Aug 20 
15:51:09 EDT 2003 i686 i686 i386 GNU/Linux

Here is successful copy using non-root id
---------------------------------------------------

[ibm@milicent SP3B2]$ pwd
/mnt/SP3B2
[ibm@milicent SP3B2]$ uname -a
Linux milicent.ltc.austin.ibm.com 2.4.21-1.1931.2.399.entsmp #1 SMP Wed Aug 20 
15:51:09 EDT 2003 i686 i686 i386 GNU/Linux
[ibm@milicent SP3B2]$ whoami
ibm
[ibm@milicent SP3B2]$ cp README.de /tmp/
[ibm@milicent SP3B2]$ mount
/dev/sda2 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
/dev/sda5 on /usr type ext3 (rw)
/dev/sda3 on /var type ext3 (rw)
skyline:/install/SuSE/SLES/8 on /mnt type nfs (rw,addr=9.3.192.95)
Salina: You need to use the '-p' option, since I think that's what tries to
copy over any ACL settings.Salina, this is a typical machine I used to reproduce
the problem: RS/6000 44P 
Model 170. The filesystem type of the partition is JFS (journaled file
system).Well, 2 mid air collisions trying to update this.
I just used strace on my cp and realized there is no getxattr.
I then tried cp -p.  The failure is same on IA32.
Getxattr fails.

I will transfer problem over to Glen Johnson.

SalinaIA32 failure on getxattr

------------------------------------------------------------

2961  utime("/tmp/content", [2003/09/11-10:26:50, 2003/04/14-11:26:26]) = 0
2961  getxattr("content", "system.posix_acl_access", 0xbff87f20, 132) = -1 EIO 
(Input/output error)
2961  open("/usr/share/locale/locale.alias", O_RDONLY) = 3
2961  fstat64(3, {st_mode=S_IFREG|0644, st_size=2601, ...}) = 0
2961  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) 
= 0xb73f4000
2961  read(3, "# Locale name alias data base.\n#"..., 4096) = 2601
Glen/Greg,
Please report this to RedHat.
Problems is likely to be on all architectures.
Please note this is BLOCKING.
Thanks
Talked to Bruce Allan, our LTC/NFS developer.
Bruce says he does not recall seeing this mentioned in the mailing lists 
discussions.  Adding Bruce to cc list so he can add insight/comments.On SLES 8
Beta 2 on PPC64.

cp -p seems to work fine, but in strace output, getxattr also fails.
---------------------------------------------
Strace shows
11373 utime("/tmp/content", [2003/09/11-08:41:13, 2003/04/14-09:26:26]) = 0
11373 chown("/tmp/content", 99, 99)     = 0
11373 getxattr("content", "system.posix_acl_access", 0xffffdf50, 132) = -1 
EOPNOTSUPP (Operation not supported)
11373 setxattr("/tmp/content", "system.posix_acl_access", 0x1001ed08, 28, ) = -
1 EOPNOTSUPP (Operation not supported)
11373 chmod("/tmp/content", 0100444)    = 0
11373 exit(0)                           = ?
------------------------------------------------------------


We intermittently experience the same problem on SLES 8 Beta 2 on PPC64.
Comment 1 Bill Nottingham 2003-09-11 17:16:26 EDT
Please try a more recent kernel.
Comment 2 Matt Wilson 2003-09-11 17:51:57 EDT
have you tested on a kernel later than 2.4.21-1.1931.2.399.entsmp?
Comment 3 IBM Bug Proxy 2003-09-11 21:36:18 EDT
------ Additional Comments From salina@us.ibm.com  2003-11-09 18:53 -------
How do we get another kernel after Beta 2 ? 
Comment 4 IBM Bug Proxy 2003-09-11 21:36:54 EDT
------ Additional Comments From salina@us.ibm.com  2003-11-09 19:38 -------
For IA32, I used rhn.redhat.com.
There is a kernel-smp-2.4.21-1.1931.2.423.ent rpm
I installed that on my machine.
The cp -p command now works

-----------------------------------------------------------
[root@milicent root]# uname -a
Linux milicent.ltc.austin.ibm.com 2.4.21-1.1931.2.423.entsmp #1 SMP Fri Sep 5 
13:59:40 EDT 2003 i686 i686 i386 GNU/Linux
[root@milicent root]# mount
/dev/sda2 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/sda1 on /boot type ext3 (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
/dev/sda5 on /usr type ext3 (rw)
/dev/sda3 on /var type ext3 (rw)
skyline:/install/SuSE/SLES/8 on /mnt type nfs (rw,addr=9.3.192.95)
[root@milicent root]# cp -p /mnt/CD1/README /tmp
cp: overwrite `/tmp/README'? y 
Comment 5 IBM Bug Proxy 2003-09-11 21:37:31 EDT
------ Additional Comments From salina@us.ibm.com  2003-11-09 19:39 -------
Olof,
I added you to cc list.
Do you know if RedHat have a corresponding version on PPC for

Linux milicent.ltc.austin.ibm.com 2.4.21-1.1931.2.423.entsmp 
Comment 6 IBM Bug Proxy 2003-09-11 21:38:06 EDT
------ Additional Comments From salina@us.ibm.com  2003-11-09 19:41 -------
On RedHat new kernel, strace shows

1591  utime("/tmp/README", [2003/09/11-18:36:24, 2003/04/14-11:26:26]) = 0
1591  getxattr("/mnt/CD1/README", "system.posix_acl_access", 0xbfe3d760, 132) 
= -1 EOPNOTSUPP (Operation not supported)
1591  setxattr("/tmp/README", "system.posix_acl_access", 0x9cd6d48, 28, ) = -1 
EOPNOTSUPP (Operation not supported)
1591  chmod("/tmp/README", 0100444)     = 0 
Comment 7 IBM Bug Proxy 2003-09-12 00:29:40 EDT
------ Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2003-11-09 22:24 -------
Salina, kernel RPM version 423 doesn't show this problem. I thought I was running this
on my victim, but it was 393.

This should be closed FIX_ALREADY_AVAIL. 
Comment 8 IBM Bug Proxy 2003-09-12 10:32:31 EDT
------ Additional Comments From salina@us.ibm.com  2003-12-09 10:27 -------
Olof,
Chinh needs a ppc64 version of that kernel.  Where do we get that from ?
Our internal restricted web site only has the iso files for beta 2, no rpm 
updates for RedHat.
    https://ftp3.linux.ibm.com/redhat/beta_cds/rhel-beta-2/ppc/
The RHN id I used is from x-series, so I seem to only find IA32 rpms.
Chinh ( JTC dev ) will need the ppc64 version. 
Can you get to that kernel level ?
Thanks
Salina 
Comment 9 IBM Bug Proxy 2003-09-12 10:37:19 EDT
------ Additional Comments From salina@us.ibm.com  2003-12-09 10:34 -------
Glen/Greg,

The IA32 version of 
kernel-smp-2.4.21-1.1931.2.423.ent.i686.rpm
shows this problem is fixed.
However, the rhn web page says 
available archs is only athlon, i686, x86_64

We need a ppc64 version of this kernel.
Can you please ask them when that is available ?

Thanks 
Comment 10 IBM Bug Proxy 2003-09-12 12:33:08 EDT
------ Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2003-12-09 12:29 -------
I get my ppc64 updates through up2date. I think the compiler team has product
entitlement numbers, so they can subscribe to up2date as well, right?

If not, I can provide the RPM as a one-time favor. Chinh, let me know. Thanks. 
Comment 11 IBM Bug Proxy 2003-09-12 12:42:35 EDT
------ Additional Comments From chtran@ca.ibm.com  2003-12-09 12:36 -------
Olof, yes would you please provide me the RPM. Thanks. 
Comment 12 IBM Bug Proxy 2003-09-12 12:57:24 EDT
------ Additional Comments From khoa@us.ibm.com  2003-12-09 12:53 -------
Olof found that this fix is actually already available, so I'd like to assign
this bug to Olof and set the resolution of this bug to Fix_Already_Avail.
Thanks folks!

Olof - I trust that you will send the rpm to Chinh...Thanks! 
Comment 13 IBM Bug Proxy 2003-09-16 17:06:00 EDT
------ Additional Comments From chtran@ca.ibm.com  2003-16-09 10:59 -------
Sorry, I did not verify the fix with the new kernel completely. Actually the 
problem is still reproducible with NFS servers running on AIX:

[vabld@vabldl7 vabld]$ uname -a
Linux vabldl7.torolab.ibm.com 2.4.21-1.1931.2.399.ent #1 SMP Wed Aug 20 
15:24:26 EDT 2003 ppc64 ppc64 ppc64 GNU/Linux
[vabld@vabldl7 vabld]$ rpm -q kernel-2.4.21-1.1931.2.423.ent.ppc64pseries
kernel-2.4.21-1.1931.2.423.ent
[vabld@vabldl7 vabld]$ cp -
p /build/extracts/xlf.lx.v1r1/xlf/web/XLFortran/design/xlf61/eertpcl.script .
cp: 
`/build/extracts/xlf.lx.v1r1/xlf/web/XLFortran/design/xlf61/eertpcl.script': 
Input/output error
[vabld@vabldl7 vabld]$ 
Comment 14 IBM Bug Proxy 2003-09-16 17:06:49 EDT
------ Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2003-16-09 11:14 -------
Above test was done with 399 kernel, not 421. Notice the output from uname. 
Comment 15 IBM Bug Proxy 2004-01-21 08:29:12 EST
----- Additional Comments From olof@us.ibm.com(prefers email via olof@austin.ibm.com)  2004-01-20 18:12 -------
Sounds like this is tested. 

Note You need to log in before you can comment on or make changes to this bug.