Bug 104259 - rhn-applet don't indicate when new packages are available in "Beta Updates".
Summary: rhn-applet don't indicate when new packages are available in "Beta Updates".
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhn-applet (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Keywords:
: 106249 106549 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-11 20:00 UTC by Féliciano Matias
Modified: 2007-11-30 22:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-03 15:27:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Féliciano Matias 2003-09-11 20:00:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
up2date and http://rhn.redhat.com/ indicate that there are new packages
available but rhn-applet don't (rhn-applet-gui and rhn-applet-tui).
To be honest, i never see rhn-applet turning red with severn.

Channels :
Red Hat Linux (Severn) 9.0.93 - Beta
Red Hat Linux (Severn) 9.0.93 - Beta Updates



Version-Release number of selected component (if applicable):
rhn-applet-2.0.10-6

How reproducible:
Always

Steps to Reproduce:
Launch rhn-applet. 

Additional info:

Comment 1 Aleksey Nogin 2003-10-03 16:56:09 UTC
I see this too - rhn-applet does not notice new packages in the "Red Hat Linux
(Severn) 9.0.93 - Beta Updates" channel. May be it just "forgets" to look beyond
the primary channel?

Comment 2 Chris Ricker 2003-10-03 22:07:18 UTC
Exactly -- with Fedora test 2, it looks like it notices changes in the primary
channel, but not in subchannels

Comment 3 Daniel Veillard 2003-10-04 00:21:57 UTC
*** Bug 106249 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Veillard 2003-10-08 11:35:58 UTC
*** Bug 106549 has been marked as a duplicate of this bug. ***

Comment 5 Alexandre Oliva 2003-10-18 20:56:47 UTC
rhn-applet-2.1.1-1 reported updates available in several non-RHN channels for
me, so I'd guess the problem of checking only the base channel is fixed, no?

Comment 6 petrosyan 2003-10-30 00:25:40 UTC
in a fully up2date system rhn-applet-2.1.2-1 still does not report about new
packages.

it goes red only after right-clicking on it and selecting "Check for updates"

Comment 7 Daniel Veillard 2003-10-30 09:04:51 UTC
Yes I have seen it both working and not working in this respect.
I have not been able to debug this yet,

Daniel

Comment 8 Marc Williams 2003-11-19 22:38:40 UTC
The same thing just happened to me with FC1.  I knew there were a few
updates in the updates dir but about 7 hours later, my icon still was
a blue check instead of a red bang.  Right clicking on the icon and
telling it to "Check Updates" caused it to immediately turn into a red
bang.

Comment 9 Chris Stankaitis 2003-11-25 21:13:20 UTC
same issue, FC1.  up2date -l will show many new packages in
http://fedora.redhat.com/updates/released/fedora-core-1/headers/header.info.

but RHN Alert Notification Tool shows no updates with the following
message.

The applet has been unable to access the following information sources
in its last attempts: fedora-core-1 @
http://fedora.redhat.com/releases/fedora-core-1, updates-released @
http://fedora.redhat.com/updates/released/fedora-core-1 

Comment 10 petrosyan 2003-11-25 22:22:22 UTC
Chris Stankaitis, you have an old rhn-applet that cannot handle
redirects. Thats a different bug that has already been fixed in
rhn-applet-2.1.4-2 which can be obtained by typing:
up2date rhn-applet

Comment 11 Ken Snider 2003-11-25 22:46:48 UTC
rhn-applet isn't listed as an available update when I run up2date
(though, all other errata are, if I perform an up2date -l).

I get the same error as Chris, and am only offered rhn-applet-2.1.2-1
as a choice.

Any chance this hasn't been pushed to fedora-core-1 or the updates
channel?

Comment 12 Alexandre Oliva 2003-11-25 22:56:00 UTC
It's in the testing updates channel.

Comment 13 Daniel Veillard 2003-11-25 23:00:59 UTC
Yep, I think I will push it to the update channel soon,

Daniel

Comment 14 Chris Stankaitis 2003-11-26 15:28:03 UTC
just to note for the record, updating to rhn-applet-2.1.4-3 resolved
my issue.  

Thanks.

Chris

Comment 15 Féliciano Matias 2004-04-03 15:27:00 UTC
Seems fixed in FC2 T2.


Note You need to log in before you can comment on or make changes to this bug.