Bug 104302 - neat's "profiles" are worthless (as-is, at least)
neat's "profiles" are worthless (as-is, at least)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 06:15 EDT by Stig Hackvan
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-12 07:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2003-09-12 06:15:39 EDT
Description of problem:

I've been trying to use profiles in 'neat' and they just waste my time because
the app is so buggy...

one glaring issue is that all the profiles in /etc/sysconfig/networking/profiles
use HARD LINKS and when changes to ONE profile's interface are made, those
changes OVERWRITE THAT SAME INTERFACE IN ALL PROFILES.  Delete an interface in
ONE profile, and it gets NUKED in ALL profiles.

Try using symlinks.  read the symlinks to generate another column in the neat
display...so that you know what you're inheriting from...  when the current
profile's interface is modified, break the upstream link by replacing the link
(instead of just writing to it!!!)...also ask if downstream links should be
broken as well.

USE CASE:

starting in common, copy profile & rename it to foo.  all of the files in
profiles/foo ( these steps are equivalent to 'mkdir foo ; cd foo ; ln -s
../common/* .')

now make bar in the same way...  bar's files are links to ../foo/*

select foo

now edit eth0 and foo/ifcfg-eth0 becomes a regular file.  common/ifcfg-eth0 is
unchanged.  bar/ifcfg-eth0 remains a link to ../foo/ifcfg-eth0 unless the user,
when queried, asks to break the dependency, in which case it retains the old
value of foo's eth0 settings.

-- stig
Comment 1 Harald Hoyer 2003-09-12 07:09:23 EDT
>> one glaring issue is that all the profiles in /etc/sysconfig/networking/profiles
use HARD LINKS and when changes to ONE profile's interface are made, those
changes OVERWRITE THAT SAME INTERFACE IN ALL PROFILES.  Delete an interface in
ONE profile, and it gets NUKED in ALL profiles. <<

That is intended... if you want different settings for e.g. eth0 create a new
device or copy the existing one and activate this one only in your preffered
profile..

Note You need to log in before you can comment on or make changes to this bug.