Bug 104361 - kudzu removes existing ethernet card configurations on 2.6 kernel
kudzu removes existing ethernet card configurations on 2.6 kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: kudzu (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-13 10:11 EDT by Chris Ricker
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 14:51:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-13 10:11:21 EDT
I know this is Cambridge++

I'm running rawhide on my laptop. eth0 is:

00:12.0 Ethernet controller: National Semiconductor Corporation DP83815
(MacPhyter) Ethernet Controller

eth1 is a cardbus wireless adapter (orinoco_cs driver)

When I run rawhide with the 2.6-test5 kernel, kudzu at bootup states that my
NatSemi MacPhyter network card has been removed from the system and offers to
remove the configuration. When I agree, it removes
/etc/sysconfig/network-scripts/ifcfg-eth1 (not ifcfg-eth0, which actually is the
NatSemi card)

When I boot up a second time, kudzu again states that my NatSemi MacPhyter
network card has been removed and offers to remove its config. When I agree, it
then removes /etc/sysconfig/network-scripts/ifcfg-eth0

Two problems here. The first is that it's detecting the card as being removed
when its very obviously still there (it's integrated), though that I might
expect since device enumeration often changes between kernels and such. The
second is that when it removes the config for that card, it removes the wrong
config file.
Comment 1 Bill Nottingham 2003-09-14 21:45:45 EDT
What's the output of kudzu -p -c network under both 2.4 and 2.6?
Comment 2 Bill Nottingham 2003-09-14 21:46:04 EDT
Also, do both drivers support ethtool?
Comment 3 Chris Ricker 2003-10-15 18:44:23 EDT
On 2.4, it's:

[kaboom@skuld kaboom]$ sudo kudzu -p -c network
-
class: NETWORK
bus: PCMCIA
detached: 0
device: eth0
driver: orinoco_cs
desc: "Linksys Instant Wireless Network PC Card WPC11 v3"
vendorId: 0274
deviceId: 1613
function: 0
slot: 0
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: natsemi
desc: "National Semi|DP83815 (MacPhyter) Ethernet Controller"
network.hwaddr: 00:0B:CD:E9:0E:A5
vendorId: 100b
deviceId: 0020
subVendorId: 103c
subDeviceId: 0024
pciType: 1
pcibus:  0
pcidev: 12
pcifn:  0
[kaboom@skuld kaboom]$ 

ethtool works with the wired (natsemi -- eth0) interface. It doesn't seem to do
much with the wireless (orinoco_cs -- eth1) interface, but I don't know that it
should?
Comment 4 Bill Nottingham 2004-02-04 01:38:01 EST
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.
Comment 5 Bill Nottingham 2004-02-04 01:41:45 EST
Please try the kudzu-1.1.36.1-1 packages at:
 http://people.redhat.com/notting/kudzu/

These may resolve some of your issues.
Comment 6 Chris Ricker 2004-02-04 11:20:24 EST
I no longer have that laptop, so if it's something specific to that
specific integrated NIC I can't test it any more.

My current laptop has:

02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5702
Gigabit Ethernet (rev 02)

for the built-in ethernet, and still using the linksys (orinoco_cs)
wireless since the built-in wireless doesn't work with linux
Comment 7 Bill Nottingham 2005-04-28 14:51:35 EDT
This should be fixed in current kudzu; the network detection stuff has undergone
quite a few fixes.

Note You need to log in before you can comment on or make changes to this bug.